Slow sync speed, devices listed as disconnected etc.


#1

Hey folks. I’ve read the documentation and a few other threads here but none of them seem to have many replies and my hardware is different anyway.

I have a small cluster. 3 devices. 2 android phones 1 home server (running via Docker)

I’m sharing a total of about 50GB of files, mostly photos (~8MB each) and some videos (~150MB each)

My upload speed is insanely low. Only about 150KB/s which makes no sense. I used to use Nextcloud which net me local upload speeds of over 30MB/s and upload speeds over public I.P. at around 10MB/s.

Additionally my devices are all reporting connectivity and sync status differently and it seems to take a long time and multiple app “restarts” for them to change.

My server says 2/3 are Out of Date. Both my phones say 3/3 Up to Date.

I know this depends on the sync options but all of them are set the same (2-way). This is still the case after 5 hours of no changes.

The server I’m using has a 3.2Ghz Quad Core and 32GB of ECC DDR4 RAM, 2x 500GB SSDs as a cache drive and 4x4TB of storage. Files are moved to the main storage every 24h or when the cache drive fills up (which is basically never). So I shouldn’t have any real I/O issues.

My Router is an Asus RT-AC68U, my server is connected via bridge 1Gbps Ethernet and my phones are on 5Ghz Wifi. So I have no idea why the speeds are so bad and what the connectivity issues are.

However, at times I do use NordVPN on my devices (some will have it on or off) but it doesn’t seem to make any difference to speed (if I turn everything off).

Any ideas?


#2

Sorry I forgot some logs. (Tried to omit any personal data):

 2018-05-11 14:30:24 syncthing v0.14.47 "Dysprosium Dragonfly" (go1.9.4 linux-amd64) root@75f3056e79b6 2018-05-04 22:05:29 UTC [noupgrade]
2018-05-11 14:30:24 My ID: *******-*******-*******-*******-DGTLYLK-2KZ5HJK-U7YX5U4-*******
2018-05-11 14:30:25 Single thread SHA256 performance is 198 MB/s using minio/sha256-simd (147 MB/s using crypto/sha256).
2018-05-11 14:30:26 Hashing performance with rolling hash is 174.21 MB/s
2018-05-11 14:30:26 Hashing performance without rolling hash is 192.18 MB/s
2018-05-11 14:30:26 Rolling hash enabled, as it has an acceptable performance impact.
2018-05-11 14:30:42 Joined relay relay://46.22.48.180:22067
2018-05-11 14:30:47 Detected 1 NAT service

(Jakob Borg) #3

To begin with, https://docs.syncthing.net/users/faq.html#why-is-the-sync-so-slow


#4

Thanks, I’ve read that. I’m not connected to an array. It just has “address” listed. Also my CPU utilisation on my Android phone (HTC U11+) is only 2.6%. So it’s not a CPU problem it seems either. Generally it sits around 1.8% and never hits higher than 3%.

Upload speed is still only about 150KB/s to my home server. My mobile devices are transferring files at around 50MB/s over LAN. So that’s problem solved. Even though I’ve checked dozens of settings it seems the server can’t be found locally, only via relay.

Any other ideas?


#5

I can’t seem to edit the above post. So I’ll make another.

I think I got it sorted (really hope so). Basically my server (docker app) running on Unraid was set to use “Bridge” connection but not the actual physical bridge I had set up which is “br0”. I deleted the docker app and reinstalled it whilst changing the former mentioned settings and added an additional mapped port (22010) and then changed the listen port to 22010 to prevent the “connected to myself, not supposed to happen” error.

I also gave it (the docker app) a static I.P. address this time.

After a restart it seems the server now instantly finds the clients and starts syncing without any issues. Logs show ports mapped successfully. I don’t know if that was really what the problem is, as I also port forwarded TCP 22010, 22011 and 22012 for all 3 of my devices and set them differently to avoid conflicts.

At least it seems to be working. Upload speed is now around 50MB/s which is hundreds of times faster than the speeds over Relay that I was getting before.

Obviously to troubleshoot this issue I disabled connecting to the relay entirely on each of the devices.