Slow local sync

Do these speeds look normal for a local network?

I don’t think network or disk are bottlenecking anything. Here’s the OpenWRT stats for the phone:

image

Task Manager:

They’re not a bunch of tiny files either. As can be seen in the 1st pic, they’re 4 big media files.

The ips are hidden, so its not obvious its actually “local”.

Androids storage abstraction has also show to not perform well. Suggest you try with 2 computers.

1 Like

Just tested with my Pixel 4a and got ~50MiB/s synchronizing a few GiB to the phone connected to 5Ghz Wifi (and 1 other device connected to that 5Ghz Wifi).

Maybe it’s because you are both downloading and uploading, as Wifi cannot do full duplex; or Wifi chatter by other devices.

2 Likes

The address field is 144...143:443. So it’s not detecting as local?

Edit: although when it’s disconnected it changes to:

dynamic
quic://71...193:22000
no recent network activity (11:55:00)
relay://144...143:443
tcp://71...193:22000

That’s still quite slow for a local transfer, though certainly not as bad.

When I was downloading only, it was ~10 down and ~0 up. So it looks like it always adds up to ~10.

50MiB/s. Your typical network speeds are measured in Mib/s. So we’re talking about 200Mib/s which is not too shabby.

1 Like

Per the address, you’re connected via relay. You need to figure out why they can’t connect directly and solve that.

1 Like

What would the address be if I were connected locally?

Not relay, and usually starting with 192.168 / 10. / 172.16

Well, it doesn’t say relay, and I’ve also disabled Global Discovery (which seems to have made it stop working altogether).

I am able to ping the phone from the computer using its “192” address.

It says relay right in the text you quoted?

And you shouldn’t disable global discovery. Just disable relaying if you want to prevent that. Also the 192.xxx address apparently wasn’t discovered based on the addresses you posted above. You should check the discovery status on that devices (web UI > This Device > Discovery).

That’s only sometimes when it’s disconnected. Most of the time there is no mention of “relay.”

Okay, I’ve reenabled global discovery, and it’s now showing a 192 address for the phone. Idk what has changed but seems fixed :sweat_smile:

Indeed that’s a somewhat weird discrepancy: Discovered addresses are shown with schema, connected ones without - we probably should show it all the time. You can get the information by hovering over it when connected.

Also glad to hear it’s working now.

2 Likes

Most likely: Android API level 30 breaks interface address discovery · Issue #1628 · syncthing/syncthing-android · GitHub