Slow LAN-Speed


#1

Hey there,

I’ve already read through the documentation and searched online for a solution but I still couldn’t figure out why the transfer speed via LAN is so slow (6mb tops).

I tried to open specific ports on my router and assigned static IP-adresses but neither goes the connection through the selected ports, which I entered with the IP-adress in the correspondent ‘Adresses’ of the devices in the advanced settings, nor did it improve the speed at all.

The devices connect without relaying, UpnP is no option and I’ve unchecked ‘Enable NAT traversal’, ‘Global Discovery’ and ‘Enable Relaying’ in the connections tab.

I’m using a Ubuntu 16.04 on the one end and a LinuxMint 18.3 on the other.

What further information do you need to answer my question? What else can I test for?

Thanks in advance.


(Audrius Butkevicius) #2

Check for bottlenecks on disk/cpu as its syncing. Also, if its a lot of small files slow speed is expected as database management per file slows it down.


#3

Hello Audrius,

thanks for the fast reply.

The disks have 5400 and 7200 rpms, but on my notebook, which runs Ubuntu, is quite old, the CPU works around 20% to 50% per core (dual) and even spikes to around 90%. My desktop computer - which runs Mint - only has a load of maybe 10% per core (quad). Do you think it’s the older CPU? Are there sort of optimal settings for LAN-setups for Syncthing?

I’m transferring video files with ~650mb per file so I don’t think the latter is the case.


(Audrius Butkevicius) #4

No, but I’d check iotop.

Can you post screenshots from both sides with devices expanded?


#5

Are any of the devices on WiFi?


#6

From the desktop computer:

Screenshot%20from%202018-06-07%2019-31-26


#7

From the notebook (Wifi):

Screenshot%20from%202018-06-07%2019-31-59


#8

From the desktop computer while notebook is disconnected:

Screenshot%20from%202018-06-07%2019-33-32


#9

From the notebook while the desktop is disconnected:

Screenshot%20from%202018-06-07%2019-32-41


(Audrius Butkevicius) #10

So as someone mentioned, I’d try to hard wire both machines and test then, as it could be your wifi.


#11

Syncthing can take a moment to get get going. The GUI will eventually update with connected. The GUI also doesn’t always update instantaneously. The connection and sync will likely start happening slightly before the GUI shows it.

In same boat right now with a slow LAN sync (9.71 Mbps but this is actually better than what have been getting) with about a 30 GB sync. The sync also completely stopped (although was connected) until paused another folder that was syncing over the internet.

The above (my situation) has nothing to do with Syncthing. It’s the WiFi connection. In addition to a speed limit WiFi also has a smaller capacity to carry as much data as wired connection. Have done this before but to prove above to yourself plug your laptop in and disable WiFi. Will quickly (likely) see speeds of about 30 Mbps or better on a gigabit LAN connection for your sync.


(system) #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.