simple way to disable ipv4


(Christian Eichert) #1

I need to disable listening on ipv6. Is there a simple way?


(Jakob Borg) #2

Yep.

tcp4://0.0.0.0:22000, dynamic+https://relays.syncthing.net/endpoint


(Christian Eichert) #3

Hey, thank you very much, but for some reason my config.xml is in xml format. or in another way round: where do i need to input this?

christian


(Jakob Borg) #4

In the settings dialog, connections tab, sync listen address field.


(Christian Eichert) #5

thank you very much. It worked great.

Communicating with you I got a idea. Is it possible to access the syncthing local website thru ipv6 in order that I do not have to use nat ? Something like http://[2001:db8:a0b:12f0::1]:8384 ?? How do i compute the ipv6 IP that passes the nat?


(Eser Gozcu) #6

Hello Christian,

By saying local website do you refer to Syncthing gui which is by default 127.0.0.1 ? If you would like to change this address to something else(including ipv6) you can use WEB Ui --> Actions --> Settings --> GUI --> GUI Listen address.

to try the ipv6 equivalent of 127.0.0.1 , you can type ::1 and from a web browser you can visit the address by typing [::1]:8384

Before you try above, I would like to add couple of more notes on this. localhost address such as 127.0.0.1 is not being NATed, in fact you can disconnect your computer from your network and I am almost sure that you can still ping that address.

You have a loopback adapter that has the address of 127.0.0.1 and by sending traffic to that address you basically send it to yourself right away without going to your router etc. So I would not worry about NAT part at all :wink:

Moreover just for the sake of curiosity, I tested [::1]:8384 and except safari browser all others just worked fine.


(Christian Eichert) #7

of course not to 127.0.0.1 but it could be 192.168.1.10 and the ipv6 would be 0:0:0:0:0:ffff:c0a8:10a
( i was not able to connect to it like http://[0:0:0:0:0:ffff:c0a8:10a]:8384 )

Then I tried “ipconfig /all” from that windows computer and I found out a ip6 address in the “Ethernet adapter Local Area Connection:” fe80::…
So I tried to connect from outside to this in the format described above but I was not able to connect to the GUI.
Could it be because it is a intranet address ? fe80 ?

but somehow it must work, because when i turned off listening on ipv6 and turned off nat the two computer didn’t find each other any more.


#8

IPv6 addresses starting with fe are link local addresses. That means, that they only work inside your network and you have to add the link. So if you have computer A with the address fe::1 and you want to connect from computer B which has a LAN link on eth0, you need to use fe::1%eth0 to access computer A from computer B.

You can use ULA with addresses starting with fd for local addresses without the need to add the link.

If your internet connection has IPv6 you need to check your router. There should be an option to open IPv6 ports for specific addresses inside your LAN.

Depending on your configuration, your PC wight only generate temporary IPv6 addresses, which wont work for external access, as they change multiple times per day. the “static” ones use the Prefix from your ISP with a suffix generated from the MAC address.