Simple Setup - Folder Marker Missing

I add a folder to SyncTrazor (Windows 10) and sync it with an unRaid server. .stfolder is created on my source drive, but I still get the folder marker missing error.

Other folders with the same source/destination machines work without problems. v1.27.7 on both machines. I have tried Ignore Permissions and I think I’ve done every permutation of deleting and rebooting on both ends before asking for help here.

Any ideas are welcomed.

Depending on what the source directory is used for, there might be some kind of cleaner routine removing the empty marker folder. Pull up the file manager and manually verify that .stfolder still exists.

It’s still there. The error pops up within seconds of accepting the sync – seems likely not enough time for something else to interfere. Thanks for the suggestion.

So the error is being reported by the UnRaid server?

Correct. The error message is: 2024-05-26 23:20:14: Error on folder "D:\\TestMe" when the the folder being shared is: D:\TestMe

So when you confirmed that .stfolder existed, was that on the Windows 10 PC?

Correct. On the unRaid side, I’ve tried both creating the destination folder myself manually or having syncthing create the destination folder, which it does accurately. In either case, there is no .stfolder file.

This is confusing. You seem to be confirming multiple contradictory things.

Sorry for the confusion:

Source:

  • SyncTrazor (Windows 10)
  • .stfolder is created

Destination:

  • unRaid
  • no .stfolder
  • Error: 2024-05-26 23:20:14: Error on folder "D:\\TestMe"

So based on that; UnRAID is a Linux-based system. It will not have a directory called D:\\TestMe, unless you’re intentionally doing something quite weird indeed. A path name on the UnRAID server will likely be something Unixy like /mnt/user/whatever.

If you’re somehow describing this confusingly and that path name is used on Windows, you don’t want the double backslashes.

As usual, screenshots would be worth a lot here, because we could see what’s actually going on.

You’re right. D:\\TestMe is the folder label. The actual folders are:

  • Source: D:\TestMe
  • Destination: /media/Backup/TestMe

In my container, /media is mapped to /mnt/user That works with other folders I’ve added previously.

Then I suspect Syncthing simply doesn’t have permissions to create the marker. That’s the traditional problem on NASes. If you want more help troubleshooting, post screenshots and logs.

It means that Syncthing running inside your container on your Unraid server must be able to create the path /mnt/user/Backup/TestMe on the host side – i.e. Syncthing requires write access to /mnt/user/ to create the /mnt/user/Backup directory before it can create the TestMe directory.

You’ll need to verify that every directory in the path is accessible to the Syncthing user inside the container.