Shared folder won't discover files/folders

image

This shared folder (drive) refuses to scan or discover the many files and folders on it. image

I’ve removed and added the share multiple times, but it never does a full scan. How can I get Syncthing to fully scan this drive?

Thanks.

BTW, I have two other drives that are configured identically, and they are working fine.

Your settings look a bit strange: one minute rescan interval, but watcher disabled?

Have you tried the “Rescan” button manually? Any error message panels appearing? Might want to look inside the log, and possibly enable model and scanner debug facilities.

If you were to enable the file system watch, please note that it currently doesn’t work for the root of a drive. The top-level sharing must be at least one folder below that. Do your other shares actually work on the whole drive?

I disabled the watcher because I’ve been reading that it’s not reliable. Opted to increase scan frequency, instead. I didn’t know that it doesn’t work on root directories. That’s another reason not to use it. There are many files and directories in the root, same as with the other two working drives.

The Rescan button returns immediately with no apparent action and no error messages.

I originally had a problem with this drive where I had put two different folder IDs between this computer and the other one that it’s sharing with. I think I got that straightened out. I thought there might be a problem with the indexes between the two machines. So, I deleted the shares on both, hoping the indexes would be removed. Then I added the shares back, but no luck.

I’ve tried adding the share with and without the backslash (H: and H:) Neither one works.

I’ll try your log suggestions next.

Why is there a password on this share? I don’t remember putting it there, and it refuses to go away. I delete it. But when I save it, it comes back.

Oops. Never mind about that last thing. My password manager was messing with me. Fixed it.

Thanks.

The slash shouldn’t matter. Syncthing doesn’t seem to be able to see anything inside the folder. Can you show what Windows Explorer displays when you right-click and view the folder properties?

image

I also tried putting everything in a subfolder, but no luck.

Enable fs and scanner tracing in the log window, then hit rescan, then post those logs and maybe we’ll see something useful.

syncthinglog.txt (4.3 KB)

Here you go, Jakob. Thank you very much. :smiley:

As far as I can tell, as far as Syncthing is concerned, the only thing that exists under H:\ is $RECYCLE.BIN. If there’s anything else under H:\ it seems to be entirely invisible to Syncthing. I don’t know what that is or how it might come to pass. Maybe if you showed screenshots and explained what is there we might understand.

image image

The only thing I can think of is Syncthing is not looking in the same place as Windows file explorer is.

(I blacked out the file names because this is my roommate’s porn collection. XD

Is this a local drive or something mounted? What happens if you try running Syncthing as Administrator?

This is a local USB drive. I am trying running Syncthing as Administrator. After adding myself as a new device and a new (test) shared folder, it is acting a bit differently. It does not immediately return from scanning. image

Earlier, out of frustration, I copied the files on this drive over to the other system by other means. This might be why it has only found the $RECYCLE.BIN out of sync. But there is still nothing in the Local and Global State. But I don’t yet understand what those are.

Has it finished scanning yet? Judging from my experience with Windows, I’d assume almost certainly that this is some kind of a permission-related issue. If I were you, I’d try to move the files to a different storage media first, then format the disk clean, then copy the files back but using robocopy /e from the command line. The reason is that Robocopy by default doesn’t copy any ownership and ACL related information (see https://learn.microsoft.com/windows-server/administration/windows-commands/robocopy).

It’s at 20-some percent. It’s a lot of data for USB to handle.

I’ll get back to you. And, I’ll try that robocopy when the scan finishes.

Thanks.

Yes, it’s syncing now. I can see it on both computers. I’ll be addressing the permissions issue soon. Thank you so much for your help. Please let me know if there’s anything you need from me.

And the robocopy technique worked like a charm. :smiley: