Setup Problems with paths


(Micha Btz) #1

Hi there,

for the moment I test if syncthing is the right tool for me. My setup: dietpi on a raspi3 Android phone linux desktop

Since the desktop is not running all the time and the phone doesn’t have connection to the internet all the time, I think the best solution is to make dietpi to the “master” because it running all the time and has permanent internet access.

But this seems not to work,if I share my backup dir from desktop to dietpi and from dietpi to the phone, it creates even a share between phone and desktop. What will be the right way to do this?

And one thing drives me crazy, on the phone I can choose in which directory the files was donwloaded on dietpi and desktop not. All the time syncthing creates paths like the orginals: If I share /home/test/media/own/backup syncthing creates /home/dietpi/home/test/media/owncloud/own/backup and on my desktop all shares lands automatically in ~. How can I set the standardpath to /home/test/syncthing and all files are going to there?

thanks Micha


(Kluppy) #2

I am guessing introducer is ticked on the phone and desktop… If so you will end up with a three way sync which should still work for you.

This will only happen if you have set the pi and the desktop to auto-accept shares. If you disable auto accept you can set each directory manually or you can change the default destination in settings.

How have you got it configured? If you share / and use ignore pattern you will get the entire path as you have described. If you just want to share the the backups folder without the full path you should set the folder path to /home/test/media/own/backup


(Audrius Butkevicius) #3

Most of the master business is explained in the docs. Master means do not accept changes from anyone.


(Micha Btz) #4

thank you both, now it is working.


(system) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.