setup of syncthing incomplete

I have version v1.3.4, Linux (64 bit) installed on my laptop and on a remote computer to which I have only ssh access. The gui on my laptop showed up nicely then I added another device, giving the id from the remote computer. The remote computer then shows as a device but its status is “disconnected.”

Clicking on the remote device’s name drops down a list of addresses which include the correct ip address of the remote unit. So I take it that the computers are aware of each other but the status of the remote computer remains disconnected.

The Sync folder has been created in the home folder on each computer but there is no folder called default. What can I do to advance matters? Suggestions very welcome.

Dave

Please post screenshots.

like this?

also I’ve started getting messages like this:

[EETCV] 13:53:19 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 149.56.130.157:22067 (relay-server) rejected: unknown device

[EETCV] 13:53:43 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52028 (tcp-server) rejected: unknown device [EETCV] 13:54:43 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52038 (tcp-server) rejected: unknown device [EETCV] 13:55:45 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52062 (tcp-server) rejected: unknown device [EETCV] 13:56:45 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52070 (tcp-server) rejected: unknown device [EETCV] 13:57:45 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52076 (tcp-server) rejected: unknown device [EETCV] 13:58:45 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52082 (tcp-server) rejected: unknown device [EETCV] 13:59:45 INFO: Connection from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM at 209.145.114.169:52090 (tcp-server) rejected: unknown device

the 209. address is of my laptop

if you don’t get any prompts to add that device, you probably ignored it. you can check in actions>settiings.

also whats the ID of the remote device in the screenshot? looks like there are 3 devs while you mentioned only 2.

settings shows 0 ignored devices

I don’t know about a third device, I did this on the remote system:

$ ps -A | grep sync 14127 ? 00:00:00 syncthing 14140 ? 00:00:35 syncthing

and on the remote as well in config.xml: device id=“EETCV2J-ZFQEFG5-B4QQQXQ-PAITYOG-V4DXXVK-2GQEGEE-IQIWVMH-VGAVNQ6”

and an updated screenshot

So far I know from the logs that “dave-g…” has an ID starting with EETCV. Then there’s the rejected connections from UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM.

That’s just “dave-g…”, that one is already known. The remote ID is not in the config. What I’d like to know is the ID as displayed in the web UI of “amirite” under activities>show ID. And for good measure in the web UI of “dave-g…” click edit on amirite and check the ID there.

The laptop id (local) is hostname dave-900X1B ID is UNLVGF4-HQ5BMKU-I5E3VXO-MQFGS7U-UNZBTFS-PB6ZMXE-7W3ZBWQ-ABZVZAM amirite (hostname of remote) ID is device id=“EETCV2J-ZFQEFG5-B4QQQXQ-PAITYOG-V4DXXVK-2GQEGEE-IQIWVMH-VGAVNQ6”

also I don’t see how to access the GUI on the remote, I installed using a text terminal

The FAQ has an entry on that. I’d suggest using the SSH tunnel approach.

what about this then?

bind: Address already in use channel_setup_fwd_listener_tcpip: cannot listen to port: 9090 Could not request local forwarding.

That means something is already listening on port 9090 on your local machine. It should be enough to pick a different one.

Did you check on the laptop UI or the config of the remote? Because the relevant place to look for the ignored device is the remote where the rejected messages are in the log.