Settings are not populated with Apache2 Reverse Proxy setup

I have Syncthing set up on a server with the web UI accessible behind a reverse proxy. I have noticed that if I load the settings modal, most of the text boxes do not populate.

Here is a screenshot of what I mean:

Relevant part of config:

ProxyPreserveHost On
ProxyRequests Off
RequestHeader set X-Forwarded-Port 443
RequestHeader set X-Forwarded-Proto https

Redirect permanent "/syncthing" "/syncthing/"
<Location "/syncthing/">
    ProxyPass http://localhost:8384/
    ProxyPassReverse http://localhost:8384/

    # Basic authentication of "admin:admin" so Syncthing will stop nagging
    RequestHeader set Authorization "Basic YWRtaW46YWRtaW4="

I have tried it with and without setting the authorization header from apache, so I know that is not the cause. (Don’t worry, I have my own authentication on top of this)
The only errors I have in the JS console is an error accessing the URL but I do not believe that is affecting this issue.
Any ideas on what I should try?

Check the JS console.

The only error in the JS console is GET 500 (Internal Server Error)

Have you tried a force refresh or a different browser?

I found the problem and now I look stupid. Apparently when Chrome autofills the username and password, the other boxes in the form get erased, too. It works after I remove the saved username and password from another service I am running from the same domain.

Thank you!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.