Setting Up Device Problem

Trying to set up Syncthing on Windows 10 64-bit desktop.Downloaded files, unzipped etc. Ran setup.exe and seemed to install, but when I try to start Syncthings, I get message: “Failed to initialize config: config file version (33) is newer than supported version (32). If this is expected, use -allow-newer-config to override”.

Questions: I just installed Syncthing on a similar Windows box a few hours ago and did not receive that message…Syncthing starts fine. Wondering why the difference?

I know how to edit the config file in Debian, but how does one edit that file in Windows?

And last, if I need to “use -allow-newer-config to override”, how do I do that. Newbie to Syncthing so all help appreciated.

Syncthing itself does not come with a setup.exe, so I would guess that you are trying to install and use SyncTrayzor. Is this correct?

If yes, then it also seems that you have already ran a newer version of Syncthing on that machine, which has created its own config.xml that is incompatible with the older version of Syncthing included in SyncTrayzor. If that is the case, then you need to go to the Syncthing home folder, which in Windows is %LOCALAPPDATA%\Syncthing (i.e. usually C:\Users\<username>\AppData\Local\Syncthing) and delete/rename the existing config.xml. Then you should be able to start SyncTrayzor normally.

Also, if you are completely new to Syncthing, I would recommend checking https://docs.syncthing.net/intro.

Yes, I was trying to use SyncTrayzor. I had first downloaded and installed the “core” files, and then SyncTrayzor. I think I should just have installed SyncTrayzor.

How can I completely uninstall and start again?

I did read the material you suggested. Thank you

SyncTrayzor you can just uninstall using the standard Windows 10 interface (i.e. either the Control Panel, or the Settings). If you want to completely remove the existing Syncthing configuration, then deleting the whole %LOCALAPPDATA%\Syncthing folder should do it.

1 Like

Thanks, Tomas. I uninstalled everything and re-installed SyncTrayzor. But I am getting a message in “The GUI address is overridden by startup options. Changes here will not take effect while the override is in place”

I went into the config file and I don’t see any “override”

SyncTrayzor (always) overrides the GUI address. If you want to change the overriden address, you can open SyncTrayzor, press File (top left) and then Settings → Syncthing.

1 Like

OK, I was able to get Syncthing set up correctly on a remote device, and if I enter my dynamic DNS alias: my-sub-domain.mooo.com:8384 I can connect with the remote GUI. The config file on that device is set to listen at: 0.0.0.0:8384

My question is how does my main device know to enter the URL above to sync with the remote device, and how do I configure the remote device to connect with the main device here at: my-sub-domain.ddns.net:8384 ?

Most of this is covered by the docs. Devices find each other via the discovery mechanism.

Understand now. All devices working well now. Thanks to all who contributed to the development of Syncthing…it seems to be exactly what many people need!

1 Like