Set UMASK to FreeNas Jail

Hello, I have a folder with 770 permissions, and I would like syncthing to create te new files with that permission, I tried to set the 002 umask in /etc/login.conf but with no success, can any one help me?

This is a FreeNas question really, and I don’t know the proper answer, but you could add it to whatever script launches syncthing.


umask 002
exec syncthing

(Remember to also set “ignore permissions” in the folder settings, and that weirdness that FreeNas does with different way of managing permissions, whatever it was.)

It worked 100% :slight_smile:

Thank you @calmh

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.