Running Syncthing as a service on Ubuntu Server 16.04

Trying to setup synching on my Ubuntu Server. I’ve followed these instructions which are pretty clear, but when I run this command:

sudo service syncthing start 

I get an error message which says:

Failed to start syncthing.service: Unit syncthing.service not found.

The only place that I deviated from the instructions above was instead of installing Syncthing the way the blogger suggested, I added syncthing into my PPA repositories. If anyone has any way of helping me get this going it would be much appreciated. Even if you have a link to another spot in the forum. I tried searching and couldn’t find anything. Thanks in advanced.

Ubuntu 16.04 uses systemd as default init system instead of upstart ( ) also your error message is a very systemd like message :slight_smile:

Take a look at the systemd scripts provided with syncthing, they are well written and easy to use.


They are also included by default in the right place in our Debian packages.

Usually you have to include the user who should run syncthing, like this:

# systemctl start syncthing@user.service

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.