Run on wifi without internet


#1

For privacy reasons I disabled internet access for my phone in my homerouter. But the wifi connection to my LAN is still given. Now Android Pie shows the no wifi icon in the top and under settings it shows that wifi is ok but no internet. But syncthing thinks for its run.condition that there is no wifi connection at all which is not correct. I only use syncthing in “local mode” anyway.

So it would be nice if syncthing would run on a wifi connection which doesn’t have internet.


(Catfriend1) #2

Hi, This is manufacturer specific. Most custom ROMs for example support keeping a WiFi connection without internet active and there syncthing also gets the right connection state reported by the OS. It’s not an issue with the app. You may have luck to change this behaviour on your Android OS by looking into the advanced wifi settings if there’s a “keep wifi without internet” checkbox or developer options. I’d refer you to Google / XDA forums for more help. Another strange and painful way would be putting up your own internet detection “captive portal server” and point your Android via ADB to it’s local wifi IP, then the OS gets fooled - not a good idea but the totally last way to do it if your Android is restricted by the manufacturer.


#3

In Android, apps are told that there is not Wifi, if the Wifi has no internet, as (AFAIK) Android can only use one connection, either Wifi or mobile. So if Android would tell Apps Wifi is on, the Apps would sync, but would do so over mobile data. As I see it, Android is not designed to have local “LAN” connections via Wifi while getting internet through mobile data.

So you can either disable mobile data. Then Wifi is the only connection and Android will tell Apps, that it is connected to Wifi. Or disable the Wifi only setting inside the Syncthing App, and disable mobile background data for Syncthing in the Android system settings.


#4

I think it still works with both connection on and wifi no internet, the syncing is done over wifi. It is just the run condition what is not fully correct. I use vanilla pie. But ok it is an edge-case and probably an OS problem. Thank you guys.


#5

When I tried to connect to the access point’s setup page, when I was connected to a Wifi without internet, it wasn’t possible. No connection to the internet (192.168.x.x) ip address was possible. I had to disable mobile data to be able to connect.


#6

You are right but I think somehow syncthing is doing it over WiFi anyway. At least my phone is not showing any data-usage on mobile data.