retry but not yet

Hello I tested thingsync 3 years ago, it worked well and the principle was just great. but I finally gave up because of a problem : I never knew which device was in which state (sync ?, more recent things on another machine?)

Now i try Again : Always easy installation and configuration but between 2 machines on the same local network with ethernet cable I have a machine that says it is synchronized :partying_face:, the other that says synchronization in progress :astonished: and synchronization is not even done! (Syncing (0% 6B) since 30 minutes :sob: )

why is my synchronization not happening?

Is it possible to have information on the synchronization state 100% reliable. (I’m sure I’m synchronized,I’m sure there are x files left to sync…)

I am on windows 64bit on the 2 machines, on the same network in gigabit Ethernet.

thanks in advance

You have not provided anything for us to look at.

Screenshots, logs, anything would be useful.

Also, perhaps this was a joke, but it’s not called thingsync.

This is not a joke but a mistake :shushing_face:

I can’t even describe my problem, nothing is synchronous, I never know what happens when :roll_eyes:

There I just tried on another machine of the same network, always under Windows 10 There is the addition of a machine and a sharing which is not good; machines cannot be seen but after 5 minutes without touching anything I receive an invitation to connect an ID (big ID, not the simplest machine name), via a foreign IP :scream:… after verification this is a valid ID :partying_face: so I accept There the 2 machines tell me “[otherMachine] Disconnected” :unamused:

These 2 machines have no restrictions between them

note : “up to date” is displayed on one of the 2 machines (not on the other :frowning: )the time to write this message and manage the kitchen

Sorry, but I can’t help you without the information I asked for and just based on your verbal stories.

2020-04-22 16:36:07 My ID: IRW2W47-35SZ2CT-N3L3FVY-TISB7ZF-JMEXPKO-A5TGXTP-2LA425R-HZWZLQ6
2020-04-22 16:36:08 Single thread SHA256 performance is 311 MB/s using crypto/sha256 (303 MB/s using minio/sha256-simd).
2020-04-22 16:36:08 Hashing performance is 258.14 MB/s
2020-04-22 16:36:08 Overall send rate is unlimited, receive rate is unlimited
2020-04-22 16:36:08 Using discovery server https://discovery.syncthing.net/v2/?noannounce&id=LYXKCHX-VI3NYZR-ALCJBHF-WMZYSPK-QG6QJA3-MPFYMSO-U56GTUK-NA2MIAW
2020-04-22 16:36:08 Using discovery server https://discovery-v4.syncthing.net/v2/?nolookup&id=LYXKCHX-VI3NYZR-ALCJBHF-WMZYSPK-QG6QJA3-MPFYMSO-U56GTUK-NA2MIAW
2020-04-22 16:36:08 Using discovery server https://discovery-v6.syncthing.net/v2/?nolookup&id=LYXKCHX-VI3NYZR-ALCJBHF-WMZYSPK-QG6QJA3-MPFYMSO-U56GTUK-NA2MIAW
2020-04-22 16:36:08 QUIC listener ([::]:22000) starting
2020-04-22 16:36:08 Ready to synchronize "COMMUNS" (commun) (sendreceive)
2020-04-22 16:36:08 TCP listener ([::]:22000) starting
2020-04-22 16:36:08 ...
2020-04-22 16:36:08 Relay listener (dynamic+https://relays.syncthing.net/endpoint) starting
2020-04-22 16:36:08 Completed initial scan of sendreceive folder "COMMUNS" (commun)
2020-04-22 16:36:08 GUI and API listening on 127.0.0.1:8384
2020-04-22 16:36:08 Access the GUI via the following URL: http://127.0.0.1:8384/
2020-04-22 16:36:08 My name is "BigPC2"
2020-04-22 16:36:08 Device K6B2EPW-7XYQYXM-Z2ANS7X-224SZXM-WOPPNAC-YBSCVLD-54ELQLY-XSG36Q5 is "X3-4" at [dynamic]
2020-04-22 16:36:20 Detected 0 NAT services
2020-04-22 16:36:28 quic://0.0.0.0:22000 detected NAT type: Port restricted NAT
2020-04-22 16:36:28 quic://0.0.0.0:22000 resolved external address quic://99.64.215.201:22000 (via stun.syncthing.net:3478)
2020-04-22 16:36:53 Joined relay relay://46.105.55.153:53604

This is usefull ? (machine always up to date)

I suggest you provide screenshots from both sides first, because I am not even sure I understand the problem.

1 Like

always the same request for add folder when the folder is already shared

I waited 15 minutes before these machines could be seen

(I do not have this problem between BigPC2 and X3-4, they are seen quickly. But the files transfer don’t works)

The folder ids don’t match, also both of the folders are empty.

2 Likes

now it’s the same id, thanks

T3-2-3

long long time before visibility, is that normal?

after the transfert is very slow as with the other machine,is that normal? BigPC2-2

independently of the files transfer, is it possible to have a diagnosis of the differences between machines ? To be sure and without delay of the state between several machines.

There the diagnosis is too slow to trust the state of the machines.

Thanks

They are NOT the same:

image

Transfer will depend on the best connectivity available. It’s not visible in the screenshots what sort of connection it’s using.

If no direct connection is available, because of firewalls, NATs etc, they will connect via a relay (intermediate party) which might have rate limits. Also, the process for connecting over a relay might take more time.

There are certain steps you can take to make sure they connect directly and have best speed, but it’s all described in the documentation, so I’d suggest you study that in detail, as a lot of your questions will be answered.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.