request canceled while waiting for connection


I have an issue for which i am not sure how to handle. I do not know if this is a bug or not.

A: syncthing running on sinology NAS B: syncthing running on Windows 10, 64bit, redsotne 1 C: syncthing running on 64bit Debian 8 LXDE D: syncthing running on 64bit WIN 10, treshold 2 E: syncthing running on os x yosemite

All versions are 0.14.6, settings on all of them are default.

B and C are on the same network (NAT) A is not there is a firewall in between them D is on a different network E is on a different network

B can connect to A via a relay B can connect to C C can NOT connect to A D can connect to A via relay E can connect to A via relay…

The confusing part is B being able to establish connection to A while C can not, yet they are both on the same network.

This is a link to output of STTRACE=discover syncthing

(the site does not allow me to post links)

I did not bother censoring any data such as device ID etc…since it does not really matter atm.

I am guessing the problem has something to do with:

request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Also, B finds 2 listeners and 5 discovery. C only has 1 listener and 2 discovery.

This has all worked for me before, on a previous setup.

I tried both, running syncthing downloaded as tar.gz and adding it via release channel, no difference.

What am i doing wrong?

Are you sure that all have the same / default config?

This sounds to me, that B has IPv4 and IPv6, while C only has IPv4. And that C has disabled local discovery. We currently have 4 discovery servers running (2 IPv4, 2 IPv6). And for every protocol (v4 + v6) Syncthing will use local discovery. Every connected discovery server and every activated local discovery will be counted here, with a max of 8 (6 servers + 2 local; half being IPv4 and half being IPv6). One server is currently down, so only 4 servers at the moment.

Did you make sure, that no local firewall or other security measures are preventing Syncthing from working?

There is a faculty firewall which is out of my reach. There have been no recent changes on that firewall.

Other than that, i did not set any special firewall rules on C or anywhere else. Neither did i change any configuration or set any restrictions. The faculty does not have IPv6.

C has local discovery enabled.

I am trying to paste some lines of the STTRACE=discover syncthing output but it wont let me (only allowed to paste 1 link?)

I was apparently mislead. Out of 3 possible DNS given to me only one was accessible from the network where C and B are. B is on DHCP and did not have a problem. C has static IP and only after i removed 2 problem DNS from resolv.conf it started working. It went to the problematic 2 first and maybe there was a “timeout” before it got to the 3rd one.

I don’t know what they are doing with/to the main firewall but i was originally told “there were no changes”.

After using the working DNS the relay connection was established.

It works now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.