Remote Server repeatedly disconnect/connects while syncing

(Christopher A Olsen) #1

I have a remote server that I’ve used for years and have always used FTP transfers with no issues. Recently I installed syncthing on it and on my home NAS and was able to add a shared folder between the two. Once I add new files onto my remote server and syncthing starts syncing, the webui on remote side give me a connection error and the remote device information keeps showing disconnected then reconnects and downloads some more, and continues to do that until the download is finished. When sync is finished it all says up to date and I no longer get any connection errors. I’ve opened the ports on my home router that were explained in support documents for syncthing, and still no change. I’ve attached what i think are the right logs that were generated on my remote server.

0 Likes

(Christopher A Olsen) #2

Wouldn’t let attach logs since i’m a new user.

0 Likes

(Jakob Borg) #3

I’ve “upgraded” you, and fixed it so that new users can use attachments in the future.

0 Likes

(Christopher A Olsen) #4

Thank you! Here is what i believe is the correct log?

panic-20190405-042523.log (96.4 KB)

0 Likes

(Audrius Butkevicius) #5

You are using a very old version with a bug.

1 Like

(Christopher A Olsen) #6

Under “This device” on my remote server it says version v1.1.1, Linux (64 bit) and on syncthing website it says latest version is 1.1.1, am I missing something?

0 Likes

(Audrius Butkevicius) #7

That’s the remote side, the logs have:

W73FO] 04:25:00 INFO: syncthing v0.14.36 "Dysprosium Dragonfly" (go1.8.3 linux-amd64) deb@build.syncthing.net 2017-08-10 15:31:25 UTC [noupgrade]

Which is apt-get installed.

0 Likes

(Christopher A Olsen) #8

I contacted my server provider asking about getting latest version installed and they said their apps update every week and he showed me a screen shot of version info showing 1.1.1. Could that old version be on my home NAS side? I downloaded syncthing qpkg from qnapclub.eu (https://www.qnapclub.eu/en/qpkg/692) for my qnap nas and on their webpage it shows v1.0.0?

0 Likes