remote expects to exchange plain data, but local data is encrypted (folder-type receive-encrypted)

I am running pretty much a stock Syncthing and I keep getting this error which I think is causing all my woes.

Seems simple enough except I cannot find anything marked as encrypt. I have another device with that folder but its not throwing the error. Any ideas where to start?

As far as I know this is the only place that you can change it to encrypt but its not set for it. image

Please post screenshots showing the Syncthing Web GUI in full on both sides.

And here is the client

Let me know if you need more.

On Android, please open the Web GUI using the left slide-out menu and take a screenshot from there.

All looks normal judging by the screenshots. Not sure why it errors out. Is the remote device on either side set to “Untrusted” by any chance? You can check this when you click “Edit Device” and go to the Advanced tab.

I went into Edit-> Sharing and it was saying ’ if untrusted enter the encryption password’

So I went into the Sharing on my PC and just typed in the password and things seem happy now, is there a way to mark them trusted?

I didn’t see anything about trust in advanced.

If it’s enabled, then you should disable it and remove all the passwords. All those are only needed if you want to share your folder password-protected and store it in its encrypted form using the Receive Encrypted folder type, which doesn’t appear to be the case here.

This is what I show

When I remove the password all the errors come back, though if it works by using passwords, fine by me.

Both sides have the untrusted unchecked.

Update: Removed the passwords from both sides, now it seems happy, no clue how a password got on there, but thank you for your help.

1 Like

I have exactly same thing. I have never enabled the “Untrusted” or added any passwords. I have no idea where did that come from.

EDIT. When I added another folder from another computer, “Receive encrypted” was the default option.

EDIT2. I found the problem and it is not directly Syncthing required. I had “auto-fill” on in my password manager and it recognized the Device->Sharing fields as password fields and added the passwords when I did other edits. Maybe Syncthing could enable the fields only if a device has been set “Untrusted”?

This cannot really be done because it’s possible to share both encrypted and non-encrypted folders with the very same device.


Yes, I was thinking this might be the case. Yet there still could be an extra toggle/checkbox per share to avoid turning on encryption by accident. This was a “user error”, but good UI’s protect the user from his stupidity. I don’t think I’m the only one who has enabled auto-fill on a password manager.

Two positive things came out of this bit stressful incident:

  1. I disabled auto-fill on the password manager. It’s a lazy man’s lousy feature in any case prone to password leaks.

  2. I tested Syncthing’s handling of the error situation and it seems no data vas corrupted due to Mia configuration.

For a moment I thought Syncthing would corrupt my files due to misconfiguration.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.