Remote devices showing 'Disconnected'

I cannot get my remote devices to connect. I do get discovery failures but i am unsure what they mean.

Looks like your internet connection isn’t working properly, as Syncthing cannot connect to any discovery servers. Do other web pages work? Do you have a firewall somewhere in between? At least the name resolution (DNS) seems to be working.

Thanks for the response.

Everything else on my network works fine. I have recently swapped out my USG for an Edgerouter X, the issue could be related as syncthing was working prior on the USG. I confirmed port 22000 to be open and setup correctly. Is there any thing else that i need setup as far as the router goes for Syncthing to work?

That’s the connection to global discovery servers which is failing. These are just regular HTTPS requests.

Could you check if the domains properly resolve and if you can ping the IPs?

It is resolving and i can ping it. i’m out of options :confused:


Are you using some kind of proxy?

No, i have a really basic setup. Syncthing is running in a container on my UNRAID Box. I am thinking HTTPS traffic is not getting out.

Are you running ping inside of the container?

I suspect even curl would not work inside of the container, because it probably has some weird network setup or firewall.

1 Like

i ran ping from the unraid CLI, not from within the container. when i run ping from within the container it does reply also.


Could you also test curl? Ping and working HTTPS are a few layers apart. Containers should always be treated as a separate host from a debugging perspective.

1 Like

This is what is being returned.


That doesn’t seem to be from within the container however.

Sorry misread that, i get the same output no matter where i am on the server.


And if you try with curl -k? DO you get sensible output?

i get this :confused:


I setup syncthing on a pi4 in the same environment to see if i could get it to connect and i am getting the same results, i am thinking the issue may lie at my router.

I’m running an edgerouterX, apart from port forwarding 22000, is there any other config options that would inhibit the connection to the global discovery address?

thanks, Scott

This looks ok. Could you check if your edgerouter is doing some man-in-the-middle on the certificate?

openssl s_client -connect

This was run from within the container.

Is anyone able to help with this issue?

I not convinced it’s a syncthing issue. Seems like something weird is happening in your NAS container thing. Did you try running it outside of the xontainer?