Remote devices are not connecting to new Pixel 7a with Android 13.

I just got a brand new pixel 7a and installed syncthing. I kept the settings as the default at first and scanned the QR codes of one of the other devices. It adds it but never connects and the other devices don’t ever get a new device approval notification. I’ve tried changing the Listen Addresses from “default” to as well as the default local IPv4 address, but not change. My wife has a pixel 6 with android 13 and it works for her and the only difference other than the model is her syncthing version is while mine was 1.23.7 from the play store. So tried to install as well as 1.23.6 (without “.3”) from the f-droid repository. All of which do not work on my device.

Here is the screenshots of my logs from my device:

The default already covers so this isn’t going to do anything (see I would suggest to restore the setting to default for now.

Can you include more details about what you’ve done here specifically? Do you mean something like this?

If yes, then doing so should indeed help the two Android devices connect with each other quickly, as local discovery is broken, however global discovery is also supposed to help with LAN connections by broadcasting local IP addresses as well. In the worst case scenario, the devices should still be able to connect through a relay though.

Can you open the Web GUI using the left slide-out menu in the Android app, and then post screenshots of what you see here on both devices?

For the local IPv4 Address I did “tcp://”. It is now set back to default.

Oh my gosh, I just went to the desktop PC that I’m trying to sync with to check on something else and noticed a notification from syncthing that it had a new device. I swear I’ve been messing with this for hours. I guess it just needed some time and I should have just added the device and ignored it for a little while. It’s now syncing and everything is working. Sorry to wasting your time.

No problem :slight_smile:. I assumed that you only had two Android phones running Syncthing, and connecting those with one another with non-working local discovery can be a pain sometimes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.