Remote device stuck on "Syncing" And remote&local states of one of the devices incorrect

I have three devices syncing a same folder.

  1. Device A: iMac, Syncthing: v1.22.1
  2. Device B: MacBook Pro, Syncthing: v1.22.1
  3. Device C: Windows 10, Syncthing: v1.22.1

Incorrect remote&local states

  • The remote&local states of A appears are double or triple of the numbers of B and C. While B and C hold the same numbers of files or directories.
  • I don’t know when and how it appended. I have tried to pause and resume and rescan on A. But it doesn’t work. I’ve also tried to restart Syncthing on A, and it still doesn’t work.

Remote device stuck on “Syncing”

Have you checked the list of items that are out of sync to see what might be holding up the sync process on device A?

Since device A is a Mac, it shouldn’t be as much of an issue, but incompatible filenames between different OSes are one of the most frequent issues (Windows doesn’t allow a list of symbols and reserved names to be used).

It doesn’t look like you have any ignore patterns set, so perhaps some of the out of sync items are temporary files?

Hello @gadget !
Of course I’ve set ignore patterns on each device. Here are my patters, and each of them are same.

(?d)System Volume Information

Here are out of sync items, and they are too normal…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.