relay dissapeared from but still active

I have been running relay on for few weeks without any issues but for the last few days it disappeared from page.

It is still active and I have traffic going through (as I can see on There is however less and less numConnections and less and less traffic - like it is no more advertised and only some clients connected in the past still using it.

What might be the reason for that? I have not tried restarting it yet but shouldn’t it automatically reconnect when e.g. were some network problems?

do the relay logs say anything? Sounds like it’s no longer announcing itself to the pool.

Nothing really in logs… Restart solved the issue but I am still curious what it could be.

I hoped that maybe it is known problem.

Is there anyway to increase logging verbosity for relay? Hopefully when it happens next time I can capture some info.

It should try rejoining the pool periodically and log stuff as it does that, so logs should have the explanation. I can’t recall if there is a verbose mode, -help will know.

Thx. No sign of trying to re join in log log files

Running it now with debug enabled. Maybe this time can capture some useful data.