Refusing to downgrade from 145201 to 100001

I happily clicked upgrade to the release 1.0 only to get a notice that Iโ€™m not allowed to downgrade :confused:

Seems the version control check for the macOS is not in the same mood for the 1.0 release. 0.14.52-1 macOS 10.14.2 (18C54)

Downloaded the .app instead and replaced the old one with the 1.0 and then everything worked properly again.

This was fixed and deployed today, not sure if something is cached or similar.

jb@kvin:~ $ curl -s | grep sparkle:version
      <enclosure sparkle:shortVersionString="v1.0.0-1" sparkle:version="10000001" type="application/octet-stream" url=""></enclosure>
      <enclosure sparkle:shortVersionString="v0.14.52-1" sparkle:version="145201" type="application/octet-stream" url=""></enclosure>

(moar zeroes, so bigger version)

1 Like

Perhaps my system cached some data. Anyway 1.0 is running very smooth for me! :slight_smile:

@UniqueUsername there are two updates going on with the macOS wrapper. Syncthing daemon itself and the GUI application. And I broke the auto-updater of the GUI. Sorry! :blush:

Sorry for the late reply, I donโ€™t check the forum often. I have fixed it today. See github issue #90 for more information.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.