reason for: INFO: Fetching release information: invalid character '\x00' in string literal


(Wolf) #1

Hello,

since the upgrade to version v14.46 I get the message “INFO: Fetching release information: invalid character ‘\x00’ in string literal”.

Is this some wrong setting on my side? Maybe because the client has deactivated the setting “Global Discovery”? Or is it something a dev could fix?

Thanks!


(Jakob Borg) #2

This means it got something bad back when checking for upgrades. I don’t know why that would be - the upgrade check works for me.


(Wolf) #3

Great! Thanks for the fast answer. An upgrade check that fails now and then could be all sorts of reasons here. Most likely an unstable uplink. Now I know where to look. Thanks again!


(Wolf) #4

Hm. Keeps happening on all v0.14.46 Windows clients. Not on any of the Linux or Mac clients, whatever their version. And I found it to happen on v0.14.45 Windows as well.

Interestingly, it says in the GUI where it deals with “Automatic upgrades” that those are “Unavailable/Disabled by administrator or maintainer”. I have no idea how I could have done that, or how to revert it.

I usually don’t go into the Advanced Config, but looking at the settings there I can see the option “Auto Upgrade Interval (hours)” to be “12” on all Windows machines. Seems to be the default. Is there another setting controlling the autoupgrade?

Btw: Has nothing to do with anything installed on Windows (have tested on freshly installed Win 10 Enterprise x64 v1709 VM (as well as v1709+current updates as of today). The VM is stand-alone, has internet access of course, but no config like Group Policies or anything that would interfere.

I’d like to switch one client to get the release candidates and see if it updates as it should when the next RC is made available. Too bad the GUI setting is not available…


(Audrius Butkevicius) #5

You have some corporate proxy/antivirus appliance that is intercepting the requests and causing this.


(Wolf) #6

Nope. I’m at home. I just happen to use Win Enterprise for the servers in the cellar.

The update from v0.14.45 to v0.14.46 worked. So the message can be ignored.


(Jakob Borg) #7

Try to manually load the upgrade url (it’s in the config, by default https://upgrades.syncthing.net/meta.json). Enable tracing of upgrade and look at the log (you can do this in the GUI).


(Jeroen Meulenaar) #8

I have the same issue.

If I open https://upgrades.syncthing.net/meta.json in my browser, I do get a lot of binary blobs in my output from line 690 onwards - to me it looks like the file is corrupted.


(Jakob Borg) #9

That doesn’t happen for me and I can’t figure out how it would happen. Save a copy of that file and put it somewhere, see if we can make sense of what the binary is?


(Shelby Cain) #10

I’m getting this behavior as well. Looks like binary data starting at line 690.

bad-meta-no-cookie.json.gz (13.3 KB)


(Jakob Borg) #11

I think I found the problem;

root@www:~# crontab -l
#Ansible: download releases
2,17,32,47 * * * * /opt/local/bin/fetch-releases.sh
#Ansible: fetch releases
2,17,32,47 * * * * /opt/local/bin/fetch-releases.sh
#Ansible: fetch geoip
39 08 * * * /opt/local/bin/fetch-geoip.sh
root@www:~#

Simultaneous curl ftl…