ReadyNas App Development?

Would anyone be interested in developing an add-on for Netgear Readynas? BTSync is getting worse and I would like to try an alternative. I presume I could install a debian package but some tie in to the RN GUI would be nice.

There is effort underway to create a pulse app. I will update accordingly.

Pulse is clearly not going to take off as it appears just wanted it for their own uses.

Pulse is the low-level synchronisation engine at the heart of our platform. But it is not a consumer product and never will be. You can still download and use it but we will no longer be supporting it as a separate product. If you want a standalone synchronisation engine with community support, etc., please use Syncthing instead.

Has anyone got pulse working reliably on a ReadyNAS?

I don’t know if it matters anymore. I’ve got syncthing running on a Readynas Duo v2. The NAS is running a Debian ARMv5 Linux and I installed similiar to any other Linux. I didn’t managed to start it automatically at systemstart (rc.local did not work), but due to bad performance I have not tried for a long time.

PS. Autostart is working with ‘supervisor’ Package installed and syncthing started via supervisor. Just had to add $HOME in the syncthing entry in supervisor.conf to the entrys suggested in thw wiki.

I would be also interested in syncthing for ReadyNas 6 (I have a Netgear ReadyNAS 102 (RN10200))

I don’t know how it works, e.g. does the forum here counts as feature request tracker et cetera.

+1 vote, for that it it worth.

Hopefully, ReadyNAS 102 model will be covered as well :wink:

I was also searching for a ReadyNas app.

Then, I found this post on Google:

It works perfectly! Finally!


It worked for me up until this…

systemctl enable syncthing@root.service

When I get

root@blackbox:~# systemctl enable syncthing@root.service
Failed to issue method call: No such file or directory

What NAS so you have? And what’s the Os?

I have the RN202 on the latest beta os.

EDIT: cd into /usr/local/bin

Then run that command.

on RN102 root@nas102:~# cd /usr/local/bin root@nas102:/usr/local/bin# systemctl enable syncthing@root.service Failed to issue method call: No such file or directory

The post has been updated. I just checked.

Interesting. Addons for sale

Why pay? It works flawlessly for me. It even updates.

It sad to see someone putting simple tasks such as this up for sale. Remember, the OS is linux based. It just takes a little bit of creativity to make apps work.

Thanks for the documentation, but service would not start on my NAS (RN104), I get the message (code=exited, status=203/EXEC).

Any idea?

Couldn’t find the log.

Any help is appreciated.

I had that error too, The ExecStart line from the syncthing@.service file used in the tutorial differs from where the tutorial tells to copy the binary. So I fixed it by changing the line to:

ExecStart=/usr/local/bin/syncthing -no-browser -logflags=0

Now it seems to work as intended.

You are correct.

There was a major update to Syncthing that caused this error. The post has been updated.

i keep getting the following error

-bash: /usr/local/bin/syncthing: cannot execute binary file

ReadyNas running RAIDiator 4.2.26

Any ideas?

Hi, can anyone share the information at this link? [quote=“aliendev, post:16, topic:1422”] [/quote]

It seems to be offline and can’t get Syncthing to run properly on my ReadyNAS…


Link has changed to:

both how to install links seem to be dead.

does anyone have the info they contained?