raspberry pi - start syncthing as service

Hi all,

I’m able to start syncthing manually on my raspberry pi using /usr/bin/syncthing

I’d like to start it as I do it usually in my ubuntu sudo service syncthing start

But it says

$ sudo /usr/sbin/service syncthing start syncthing: unrecognized service

$ cat /etc/*-release
PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
NAME="Raspbian GNU/Linux"
VERSION="7 (wheezy)"

Please advise. Thanks ahead.

Looking into this howto for now https://www.cuonic.com/posts/how-to-start-syncthing-on-debian-boot

Did you check the docs?

I was able to start syncthing on my raspberry pi using link I mentioned above, also I added these lines into my /etc/monit/monitrc :

check process syncthing matching "syncthing" 
start program = "/usr/sbin/service syncthing start" 
stop program = "/usr/sbin/service syncthing stop" 
if cpu usage > 95% for 10 cycles then restart

Aren’t you likely to run into issues restarting if the CPU is at 95% for 10 cycles?

I am not running ST on a Pi myself but getting it to hit 95% on an initial scan doesn’t seem unlikely to me.

This is my uptime below, see load average.

$ uptime 18:01:24 up 4:59, 1 user, load average: 0,34, 0,21, 0,29

Well, I remember when I just started syncthing on my rpi for the first time, it tried hard to sync all my 4 gb and maybe struggled all the night, I don’t know, but in the morning it was ok. Now I do not see high load at all. I run also samba and transmission, everything looks smooth.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.