Random reboots while syncing

Hey, I’m not sure if this is happening to everyone or just me.

I use a Nexus 4, and I have 6 folders syncronizing. In total there is less than 200mb, but the phone always reboot while syncing. I check logcats and the log of syncthing but there is nothing weird.

In pc-syncthing’s log, it just says that it lost the conection, and in the logcat it sais that art kill the process.

I’m using Android 5.1.1, do you want me to provide all the logs?


If there is a crash yes, or reasons why ART killed it.

I was doing some logcats, but now the phone just reboot, there is nothing weird in the logcats, they just stop loggins.

Here you got an example: link

What I noticed is that every time the phone reboots this line appears, only before rebooting, not before:

E/WifiStateMachine( 559): WifiStateMachine CMD_START_SCAN source -2 txSuccessRate=6032,67 rxSuccessRate=3213,41 targetRoamBSSID=any RSSI=-54

Also, there isn’t anything strange in syncthing’s log, so any idea?

Well if the phone reboots that implies a hardware problem. If syncthing restarts, that’s potentially a problem with syncthing.

What ROM are you using? Do you have root enabled in Syncthing? What is the CPU usage?

The log looks normal, that error is from Android I think.

Anyway, phone crashing is either a hardware or ROM problem (unless the app is using root).

It shouldn’t be a hardware problem as I play heavy games for example, and I never have randon reboots, just while this app is in background.

I was using undervolting, but I restored to stock values, but no luck.

I’m using Chroma’s rom based on aosp, and the cpu usage is around 20% while syncing. I’m not using root because then app crash. Do you think that using it as root could solve the problem?

Without a log showing an error no one can tell.

What I mean is, if the app doesn’t use root, it should never cause problems like a reboot. So I think it’s a problem with the ROM/hardware.

Does the phone get hot? It could be that the hashing overheats the CPU causing the phone to reboot.

Okey, just testing I think I found what’s causing my device to reboot (It just stuck, turn off and then turn on)

I have my pc with syncthing on, and in my device I’m syncing some folders. After syncthing-android starts, it sets the folderobserver, and I have folders like the screenshots one. When I take a screenshot, this appear in the log:

/PostTask( 3881): Calling Rest API at
V/PostTask( 3881): API call parameters: folder

So nothing wrong here, I imagine, that the syncthing android’s server is calling the app to sync, right?

The problem is that after this line, there are like a hundred other in just a few seconds, as you can see here (pastebin), but I dind’t change any other file

My thought is that syncthing-android starts a loop calling the server to sync, and due to all the continuous calls, the system just reboot to avoid that.

Could be the problem this one?

Btw, it is not due to cpu getting hot, because it’s cool after the app start (the cpu being using is no more than 10%)

How fast do those lines appear?

The app is polling every 10 seconds to update the GUI, so that would be normal.

After I take the screenshot, all this lines appears in about 3s, and they stop because the phone freeze and reboot

This is actually odd. Are you sure it’s not due to bufferng? (ie did you start logcat on another device before testing?)

Is there anything else in the logs before that? Possibliy using adb logcat -s SyncthingNativeCode:v or adb logcat *:W?

At first, another error that I have been having is that when I use the root options, it stuck loading the app:

I/SyncthingNativeCode( 545): [7T7AM] 12:05:56 INFO: syncthing v0.11.6 (go1.4.2 linux-arm android) unknown-user@android.syncthing.net 2015-05-23 23:58:46 UTC I/SyncthingNativeCode( 545): [7T7AM] 12:05:56 INFO: Database block cache capacity 14675 KiB I/SyncthingNativeCode( 545): [7T7AM] 12:05:56 FATAL: Cannot open database: leveldb/storage: corrupted or incomplete CURRENT file - Is another copy of Syncthing already running? E/SyncthingNativeCode( 545): Syncthing binary crashed with error code 1

I will delete the data and configure again the folder and tell you.

Nothing weird, It has to be my hardware:/ I need to find another one running lollipop in his nexus 4 to check if it has the same problem as me

I noticed that my neuxs 4 get stuck and reboot while syncing, so if there any way to limitate the number of folders that are being syncing at the same time?

Maybe, if we sync folder by folder or two folders at the same time, we can be sure that the device will support the activity. I can also test if this could be a possible solution if you manage to make this feature in the app

What do you think?

There is no such feature. You could try to remove some of your repos, and see if that fixes it.

@calmh @AudriusButkevicius Do you have any idea for the log above?

I think that’s just an unfinished corrupt transaction. You can fix it by removing the CURRENT file.

There’s a button in the app settings for this, “reset database”.

Yeah, I just delete the data of the app and import the config to have all my repos.

So, if it works well using a less number of repos… Is there any change to add to the android-app a setting to reduce the number of repos being syncing at the same time?

I will be testing that to tell you

Okey, I have been doing some tests.

The problem is related with the number of files that the folder have or the size they have.

I tried syncing a folder with around 100 photopgrahs and it randomly got stuck and the phone did a hard-reboot.

I also tried with a folder that had around 10 files, but they were heavy (around 150mb) and the same happened.

If I sync folders that don’t have so many files and their size is normal I have no problems.

1 Like