Random disconnects

I am trying to my best to describe my problem, please bear with me, thanks!

I am syncing with ad hoc from windows 10

Syncing between 2 computer seems fine, but trying to sync with one of my android device is problematic (and cause others to disconnects when this is connected)

It has random disconnects, and rarely gets synced

here is some of the lines from the console:

  • wsasend: An existing connection was forcibly closed by the remote host.
  • EOF
  • wsarecv: A connection attempt failed because the connected party did not respond after a period of time…

Everytime I restart the app, it freezes. I tried to force close it, and re launch it, ti freezes. I restart the whole unit, and it syncs for 5 minutes and everything gets disconnected. nothing gets reconnected unless I restart the whole device. I tried restarting the computers, and the one that host the ad hoc, and didn’t help to sync.

It’s possible that your internet connection is just bad or the phone switches networks often/does not keep wifi on.