Question on setup private relay server ...

Hello guys,

I tried to use syncthing to sync my office PC and home laptop. Things seems to be pretty good for past year. Most of time, the sync is relay mode (no direct connection between my home and office). Because most of files are very small, the speed is not an issue until last week.

In this week, I have to sync some big files (~1GB). The speed becomes a headache for me. And I decide to setup a private relay server for myself on AWS. (I’m using AWS’s first year free instance.)

The first question is that when I run relay without -pools="", I could find my relay server on https://relays.syncthing.net/. I guess everything work fine. Then, I run with -pools="" like below (make it private)

I couldn’t understand why ipv4 address is 0.0.0.0 in relay ID ?? If that’s correct, how syncthing client find this relay server?

The second question is how to correctly config syncthing client to use this private relay server? I experimently configure client as below.

The client log shows something is not correct. The document on this topic is very brief and better than nothing. I couldn’t figure out the correct way to make things happen. Please help. Thanks advance!

Here's log.

2019-11-28 15:57:04 Relay listener (relay://0.0.0.0:22067/?id=) starting

2019-11-28 15:57:04 Could not connect to relay relay://0.0.0.0:22067/?id=: dial tcp 0.0.0.0:22067: connect: connection refused

2019-11-28 15:57:04 Listen (BEP/relay): dial tcp 0.0.0.0:22067: connect: connection refused

2019-11-28 15:57:04 Relay listener (relay://0.0.0.0:22067/?id=) shutting down

2019-11-28 15:57:04 Entering the backoff state.

2019-11-28 15:57:04 c.S.listenerSupervisor: Failed service ‘relay://0.0.0.0:22067/?id=’ (2.999044 failures of 2.000000), restarting: false, error: “{relay://0.0.0.0:22067/?id= relay://0.0.0.0:22067/?id=} returned unexpectedly”, stacktrace: [unknown stack trace]

Not sure off the top of my head if it’s a bug or not that it displays the address like that at startup – but what happens “normally” is that the relay pool server then translates that to the real IP based on where the call comes from.

In your case, in your Syncthing config, you should use the relay’s real, public IP address and not 0.0.0.0.

The relay does not always know it’s own IP, hence the 0.0.0.0’s.