QNAP shared folder permission denied

Hi have been successfully running Synthing on my QNAP for a number of years, but recently I had issue where the drives all got full and backups stopped, I reclaimed alot of disk space back by archiving off the data. Then I noticed I could not launch Syncthing, web page just gave generic message not available. I tried starting and stopping the ST app but no joy so then I deleted the app and installed it again. Upon starting everything is back to first time setup. Now issue is I try to add the folder I wish to sync my clients with but not able to as its says permissions denied. I am logged into QNAP as admin, but I cant work out how to see what account the syncting app is using.

Any advice.

ps aux|grep syncthing

Is it wanted the .stignore path begins with lstat/... when other errors show path start with stat/...?

Hi, still having issues, but decided to reset QNAP back to factory settings. After I setup the shares I can now at least start the scanning of the folder but it still complains of permission denied to all the folders in the folder I want to share.

I see that when you start syncthing it creates a user called syncthing and its not a member of the group that has permissions to this folder (admin and administrators group have permissions) but even if I add the syncthing user to the administrators group it still has access denied. This folder is share out on the network and my other accounts have read and write access ok. So not sure what to do next.

and the result of PS aux|grep syncthing

s aux|grep syncthing 4332 admin 1036 S grep syncthing 13066 syncthin 18292 S /share/CACHEDEV2_DATA/.qpkg/SyncThing/syncthing -gui-address=0.0.0.0:8384 -home=/share/CACHEDEV2_DATA/.qpkg/SyncThing -logfile=/share/CACHEDEV2_DATA/.qpkg/SyncThing/synthing.log 13082 syncthin 48080 S N /share/CACHEDEV2_DATA/.qpkg/SyncThing/syncthing -gui-address=0.0.0.0:8384 -home=/share/CACHEDEV2_DATA/.qpkg/SyncThing -logfile=/share/CACHEDEV2_DATA/.qpkg/SyncThing/synthing.log

On folders settings (Advanced tab) you have a “Ignore permissions” option. Try that.

Then you can also add the user syncthing to your own group.

Please, when posting blocks of code/terminal copy-paste, use txt (surrounded with back-quotes) for in-line formatting,

and a blank line followed with
4 blank spaces beginning the next line before your text block

I have upgraded Syncthing to 1.27.7 from Syncthing - MyQNAP and got the same errors. I don’t have a solution yet but the first thing that I found is that there is syncthing user in /etc/passwd file with number 100 but Qnap is not showing in GUI any users with numbers below 1000 so I have change it using SSH and sudo (useful is to install nano and midnightcommander from myqnap repo) to 1050 and now is visible in GUI. Then I was able to edit user privileges and grant RW access to Shared folders. Despite of all of this tricks I am still stuck with permission denied. Any ideas?

Hi, in the end I gave up trying to share the file on the QNAP NAS. As it was basically syncing to my laptops. I deleted the contents on the NAS, then started the sync from the laptop upto the NAS and that worked. Perhaps I should have done it this way all along. So for me it now works.

It is no clear to me what happened/how you succeeded. Is it a special distribution on the qnap like it is for Android? I ask this because I thought that in Android we have a self created folder which, IIRC, is created “Send only” i.e. special settings.

Also, did you try to manually create the .stfolder marker folder (it seems to be missing)? Deleted or at least checked it exists?

Hi I think it is a special built one for QNAP through their app store, MyQnap

The guy who develops it has a forum, and discord but didn’t respond to my questions.

Yes after I wiped the NAS and did a factory reset the .stfolder was created automatically.