QNAP NAS File Path

Hello everyone,

I’m new here and also new to Syncthing. I immigrated from Qsync and Resilio pretty recently and I find Syncthing promisable so far. Now I run into a basic problem, maybe someone can help.

I have a QNAP NAS server and several PCs. I simply want to use my NAS as a PDF Library which means I connect all the PCs with my NAS.

I installed Syncthing on one of my PCs and also on NAS. I connected them and tried to share a folder. The synchronization itself seems to have worked, but the folder path on NAS seems to be wrong – the folder I thought I connected via Syncthing is still empty. So where was my test-file sent?

I experimented with those settings: on my server under “Edit folder” - “Folder Path” I wrote /test or /home/test making it as a subfolder of another existing folders of mine - Didn’t work. I used what was already written in the place and made a new subfolder /shared/…/Test -Didn’t work or I at least can’t see it.

Can someone explain it to me, please?

You can’t modify the folder path once it’s created, so I am not sure what you did. To change the path you’d have to remove the folder and readd the folder with the same ID.

No, it’s not about modifying the path. During the setup, I choose a file path. But Syncthing doesn’t send the files according to the file path into the folder.

The files were send somewhere else, but where?

They are sent to the path shown in the UI, it’s likely you mistyped it, or perhaps you are looking at the wrong folder if you have multiple.

Thanks for responding, I found out that this is a problem of my server, not Syncthing. The NAS File Station apparently tends to hide some files / paths or whatever.

I will sync all my divices to one PC and connect the PC to my Server via Qsync, until I solve the problem with my NAS.

Thanks!