"Public key is not available" error

Hello. I was trying to install Syncthing v1.17.0 in Bodhi 6.0.0 (focal) using the instructions given in the webpage for Ubuntu packages, but found this error when input sudo apt-get update:

W: GPG error: https://apt.syncthing.net syncthing InRelease: The following signatures couldn't
be verified because the public key is not available: NO_PUBKEY D26E6ED000654A3E
E: The repository 'https://apt.syncthing.net syncthing InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried to install using the URLs with http instead of https, but didn’t work neither.

Hope to get some help. Have a good day.

I don’t know what this is. Perhaps you need to add the PGP key differently, assuming that you already added it according to the instructions on our web page? I suggest checking the docs for your distribution.

Hi. Thanks for the answer.

Bodhi is a linux distro based on Ubuntu. Version 6.0.0 is especifically based on Ubuntu 20.04 (focal). Unfortunatelly there is no docs about Syncthing in the distro’s official website, nevertheless it’s available in the Debian Package Manager, but once I install it using the package manager Syncthing crashes everytime I try to open it. That led me to the same sudo apt-get update issue I mention before.

I’m lost. I really like the app. I used it succesfully on Android and Windows together, but I would like to use it in Linux rather.

Edit: Oh. Yes. I followed the instructions given for Ubuntu on the Syncthing web page, but it throws me the error in the former post.

Best if you ask Bohdi people whats going on, as this works on ubuntu, and none of us use Bohdi to be able to give you any meaningful advice.

Hello. Well, I tried several things (contacting Bodhi support among them of course) but didn’t find a way to install Syncthing using the apt application. So I opted for download the binary package and it has been working smooth so far. Thanks for your time. Bye bye :wave:

Hi @gatocinza, you may appreciate this link:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.