Problems syncing with NAS + very low LAN sync speed

Hello all,

After having struggled for a while, I’ve decided to talk about the bunch of things that keep my Syncthing setup from running smoothly.

(A) My hardware : 1 laptop running Windows 8.1, 1 NAS (Synology DS213j), 1 Android tablet and 1 Android phone. All of them running the latest version (let’s say 0.10.27, as I’ve just seen, before posting, that 0.10.28 is out).

(B) My Syncthing setup : kind of mirroring. A total of 10-12 repos, from tiny ones (current Office work files, <20MB) to huge ones (e.g. Music, ~ 75GB). There is NO master folder across all my setup.

Issue #1 : every item modified or deleted on PC or phone is added back by Synology. The NAS keeps acting all the time as if it was a master folder. I’ve uninstalled and reinstalled it to no avail, don’t know if I should pay attention to another particular setting. Is there any known kind of “conflict” between the official versions and the NAS one? Or should I rather report this issue to the NAS package dev ?

Issue #2 : sometimes ST continues to look for a specific deleted file over and over, on both sides of the same repo, and this leads to generating the “Folder isn’t making progress” thing. This is what I dedicated (almost) my whole weekend to, expecting to have a smooth run to start the week with. But no. Don’t worry, I’ve read all the forums and Github pages about that, but nothing positive so far.

Issue #3 : my LAN sync speed has drastically dropped to max. 80Kb/s these last days, whereas I’ve got up to 2Mb/s in the good old times. Don’t know what’s wrong. No web UI opened, and it’s same result for all the wrapper I’ve tested. And I’ve looked here too: Syncthing Very slow to LAN Sync Repo.

Please note that I’ve changed wrappers to see how it can help ST run smoothly (mainly to CPU and memory hogging, see here: SyncTrayzor: Windows host for Syncthing. Installer, auto-start, built-in browser, tray icon, folder watcher, and more). I’ve tried SyncTray and SyncTrayzor (both portable) and have now installed Syncthing-gtk. I have no preference, I’d just keep the one having the least impact on my system resources.

Sorry to have thrown it all in one topic, any idea/help is welcome.

Thanks beforehand.


  1. You should be able just to run an official ARM release from github. I guess you’d have to switch on a few more debug flags to see why NAS thinks that his file is newer (though are you sure it’s the NAS?) . I somehow have an hunch that it’s nothing todo with your NAS but rather the fact that you have 2 Android devices which is a known issue with Android where mtimes cannot be adjusted causing the issue.

  2. It seems closely related to 1

  3. When did this happen? There was some features added related to LAN, hence knowing when it started happening would be useful. You can always provide us with some profile files (see -help) to help figure out why it’s slow. Ideally blocking profile and cpu profile.

Thanks for the quick reply.

  1. Will install the official ARM release from Github in a while (didn’t notice that it earlier, my bad). I’ll investigate a bit more, but I remembered having seen Android devices syncing quite fast (in MB/s) with the PC.

  2. Noted.

  3. I’ve noticed it, let’s say 4-5 days ago. I’ve just looked here and there for a tuto on how to do a build profile files but can’t sort it out. The “-help” thing, is it for CLI ?

  1. Yeah you just set some environment variables. Also, try an older version and see if its better.