Problem with syncthing GTK

Apologies if this is in the wrong forum :smile:

I’m trying to install syncthing GTK on Debian. Actually, I think it and all dependencies are installed fine, but when I try to start it (in terminal) I get:

Traceback (most recent call last):

File “/usr/bin/syncthing-gtk”, line 18, in App(path, os.path.join(path, “icons”)).run(sys.argv)

File “/usr/lib/python2.7/dist-packages/syncthing_gtk/”, line 69, in init self.setup_commandline()

File “/usr/lib/python2.7/dist-packages/syncthing_gtk/”, line 220, in setup_commandline

aso("window",	b"w", "Display window (don't start minimized)")

File “/usr/lib/python2.7/dist-packages/syncthing_gtk/”, line 205, in aso

o.long_name = long_name

RuntimeError: unable to set value for field

I should mention that I’m accessing this machine with X2Go.

Any pointers greatly appreciated :slight_smile:

/cc @kozec

Yeah, that would be me :smiley:

@Mike_Timberlake what version of Debian are you using? Or, even better, what version of GLib? Option parsing got changed few times, so it’s possible that you found version that doesn’t support long names for argument.


Debian is version 7.9.

Beyond that, sorry to say I’m confused. This box was installed as a purely headless server, and I later installed Gnome etc myself.

As far as I can see glib is installed, but what should I do to show the version number? I get:

root@orac:~# apt-show-versions glib-2.0 glib-2.0 not installed (even not available)

root@orac:~# apt-show-versions glib glib not installed (even not available)

I just did a full install of Gnome (apt-get install gnome), which added new packages, but the error message remains the same.

I have a feeling I’m missing some dependency, but can’t figure out what


apt-show-versions libglib2.0-0

libglib2.0-0/wheezy uptodate 2.33.12+really2.32.4-5

[quote=“Mike_Timberlake, post:4, topic:5750”] -0/wheezy uptodate 2.33.12+really2.32.4-5 [/quote]Oh… To be honest, this is archaic, something like 2012 or even older… I’ll check what can be done, but there is pretty good chance that a lot of other stuff will be broken as well.

ok, thanks.

Why would this be? I’m no Linux expert, but I understand that Debian is never bleeding edge, or anything even close. I guess all Debian users would have the same problem with Syncthing GTK?

What version of glib do I need?

Well, even Debian themselves call wheezy “obsolete stable”. Much as I love Debian, you have to admit that when they say something is obsolete, it’s time to move on. :wink:

1 Like

[quote=“Mike_Timberlake, post:6, topic:5750”] What version of glib do I need? [/quote]>=2.40 would be nice, oldest I’ve tested was 2.38.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.