Problem with post-ignoring a file (sendonly>recvonly)

Follow-Up to Ignore pattern with special chars not working, v1.1.1-windows-amd64


I’m currently experiencing the same problem again. To catch up with the old thread, I now know that it hasn’t to do anything with special characters in ignores (like we concluded together at that time). So I think the thesis of calmh I’ve linked above might be true. Let me describe what happened now since I made everything fresh at the time of the old thread.

My machines net01, net02 are running on Syncthing v1.2.1 (win-amd64). The setup is: A (sendonly) > B (recvonly) I’m syncing drive F: with ignores. The ignores are (manually) set the same on both sides.

Two files of a text editor storing recent file paths went out of sync now because I worked with PSPad (editor) on B. They are plain .INI text files. A showed them out of sync, B showed to revert them. As I expect this to happen regularly and often, I chose to put a new line to the .stignore on both computers:



Both sides automatically triggered a rescan by itself and came up with:

A: image image

B: image image

I cannot get this out of sync state away - it seems to be the same issue like in the topic linked above. Tried then to restart both syncthing instances, hit rescan manually - no change in the situation. I expect A and B to be in sync as the only difference is ignored.

I can also reproduce this creating a fresh folder with the same setting on the PSPad sub directory and then make my change to the INI on B and creating the ignore patterns for the file on A+B.

Any more info you might need to investigate or fix this?

Kind regards, Catfriend1

1 Like

This is a bug, please open an issue on github, I’ll file a PR.

1 Like


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.