Problem with NAT connection

My VPS syncthing service cannot connet to my home service. Home has real IP with UPnP. In home logs I see next message:

New NAT port mapping: external TCP address 85.233.XXX.YYY:59539 to local address [::]:62351.

Detected 1 NAT service

quic://0.0.0.0:62351 detected NAT type: Port restricted NAT

quic://0.0.0.0:62351 resolved external address quic://85.233.XXX.YYY:62351 (via stun.syncthing.net:3478)

I think quic must resolve external address to 59539 port instead of 62351, because 62351 it is local port. If I write my home service address on VPS service as tcp://85.233.XXX.YYY:59539 instead of dynamic, then connection established.

Quic and tcp are different and will use different ports. Looks like it properly detects the NAT mapping so it should be announced and connected to automatically as well…

I disabled UPnP (uncheck “Enable NAT traversal”) and made port forwarding in router settings 62351 → 192.168.XX.YY:62351. Now it works.

P.S: I uses 62351 port instead of default port 22000.