Problem running syncthing as a service


I am running syncthing in both a server (W2012 R2) and a desktop machine (W10). 2012 machine is running fine but the desktop is causing some headaches. I have configured the syncthing executable to be run as a scheduled task triggered when system starts. It seems to be doing fine but syncthing dies when the computer enters the suspend status and is not recovered when going back to life. Have you ever experienced something similar?. (I have tried adding new triggers like power configuration and when internet conection is up but none seem to trigger it)

Another question coming from the same problem… Trying to solve those problems, I tried to configure syncthing as a service with nssm. It seems to be running fine but all configuration (repositories, remote machines IDs, etc…) are lost. Going back to scheduled task start up recovers the configuration… Why is this happening?. Why does not nssm read configuration correctly?.

Thanks in advance,


Try going into the “Advanced” options and turning off restartOnWakeup which is somewhere in there.

Best guess is that it runs as a different user to your normal account.

Thannks for your response. I have been reading about the purpose of this parameter but I cannot make an idea on how this could help me. I mean, why could this be happening? (syncthing not starting upon wake up).

For the second question, I have tried running both as the system user and as the local user I am using to start the scheduled task… Still guessing what the problem is.

Thanks again,


So syncthing will restart upon detecting that the system has been sleeping. If you run syncthing normally, it has two processes, the monitor process and the actual syncthing process. As syncthing restarts, the monitor process detects that and restarts it. If you run via syncthing via some service manager or some other magic which is supposed to replace the monitor process, it’s probably not doing it’s job and not restarting syncthing properly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.