Problem - folders not synching

I’m probably missing something very obvious - I’ve just installed syncthing on my Android phone and Linux computer and I can’t get folders to sync.

I’ve added a folder on the phone, which has some content it. I then added a folder on the computer with the same folder ID and set it to share with the phone. I can see on the phone that the folder is shared with the computer. But the folder does not sync.

The phone says “Idle (100%)” and “114 / 114 Files”, while the computer says “Idle 100%” and “Global State: 0 items”; “Out Of Sync: 0 items”.

On the computer I have v0.10.3, while the phone has 0.5.2 which claims to be Syncthing Version v0.10.3.

Any clue as to what am I missing?

Have you got that particular folder shared with the other node?

I’m not sure if what I did is correct - I’m familiar with btsync that has a key for each folder. What I did in Syncthing is to create a folder with a specified Folder ID, and then create the same folder with the same Folder ID in the other node.

We have an additional step unfortunately. If you pull up the editor for the folder you’ll see a checkbox at the bottom for which devices to share the folder with. Make sure the other side is checked there, on both devices.

Thanks for the response, but as I’ve mentioned on the first post - I’ve also completed that: the phone has the computer name checked under “Devices” for the folder, and the same on the computer.

I guess it could be that you’re NAT’ed out on both ends without an ability to communicate directly between the devices. I assume both ends show the other device as offline?

Currently both nodes are on the same LAN and show each other as connected and “Up to Date”.

But one of the nodes is missing files. or are the files just different?

The computer’s shared folder is pointing to an empty directory - I want it to pull the files from the phone.

BTW - with STTRACE=model, the computer has this to say:

[TFK5P] 2014/10/27 16:33:53.777771 main.go:905: INFO: Established secure connection to 7THA2MJ-TKO4EGB-3SGJKBZ-Z5KVEVN-FUCZPTH-ZACQP3A-AW2SQRV-7E2ECQ4 at [fe80::f2de:f1ff:fe10:8f46%enp0s25]:22000-[fe80::2e54:cfff:feea:dd0c%enp0s25]:46904
[TFK5P] 2014/10/27 16:33:53.778055 model.go:852: DEBUG: sendIndexes for 7THA2MJ-TKO4EGB-3SGJKBZ-Z5KVEVN-FUCZPTH-ZACQP3A-AW2SQRV-7E2ECQ4-[fe80::f2de:f1ff:fe10:8f46%enp0s25]:22000-[fe80::2e54:cfff:feea:dd0c%enp0s25]:46904/"mobile-downloads" starting
[TFK5P] 2014/10/27 16:33:53.778414 model.go:926: DEBUG: sendIndexes for 7THA2MJ-TKO4EGB-3SGJKBZ-Z5KVEVN-FUCZPTH-ZACQP3A-AW2SQRV-7E2ECQ4-    [fe80::f2de:f1ff:fe10:8f46%enp0s25]:22000-[fe80::2e54:cfff:feea:dd0c%enp0s25]:46904/"mobile-downloads": 0 files (small initial index)
[TFK5P] 2014/10/27 16:33:54.125371 puller.go:134: DEBUG: puller/mobile-downloads@0xc2083a82d0 skip (curVer == prevVer) 0
[TFK5P] 2014/10/27 16:33:54.432392 model.go:528: INFO: Device 7THA2MJ-TKO4EGB-3SGJKBZ-Z5KVEVN-FUCZPTH-ZACQP3A-AW2SQRV-7E2ECQ4 client is "syncthing v0.10.3"
[TFK5P] 2014/10/27 16:33:54.432510 model.go:531: INFO: Device 7THA2MJ-TKO4EGB-3SGJKBZ-Z5KVEVN-FUCZPTH-ZACQP3A-AW2SQRV-7E2ECQ4 name is "localhost"
[TFK5P] 2014/10/27 16:33:55.125639 puller.go:134: DEBUG: puller/mobile-downloads@0xc2083a82d0 skip (curVer == prevVer) 0

Then it repeates the last line every second or so.

Can you check the rescan interval on the phone? I have a feeling that the files on the phone haven’t been picked up… Which might be due to 0 rescan interval…

Alternatively, add a new empty file to perhaps trigger an update and version bump.

The rescan interval on the phone is 60. I’ve added a small file, and the UI on the phone has increased the file count - but the computer’s debug outptu still says

"mobile-downloads": 0 files

Opening the web UI on the phone, I see a notice:

"Unexpected folder ID “mobile-downloads” send tfom device "

Check for spelling and typos, it seems that you might have misspelled the folder name somewhere? I guess you should be getting same type of messages on the other node? If not, perhaps the folder is shared on one device but not the other?

I guess you could post screenshots which would help us debug the situation.

Here’s how this looks on the phone:

And this is on the desktop:

I don’t get the “Unexpected folder” notice on the computer.

Ok, interesting - now I noticed that in the web interface on the phone you can see that the folder is only shared with “localhost” (which, if I understand correctly, the phone itself) while in the phone UI both external nodes are checked.

From more testing, it looks like when you create a new folder from the phone UI, it has all external nodes selected by default, but it does not actually enable sharing with them - as can be seen in the web UI. I can unselect all nodes, exit from editing, get back in to select the nodes again and only then it works.

Currently it looks to be syncing fine.

1 Like

I can confirm this issue on a Galaxy S4. The share checkbox was automatically checked in the app GUI but when I switched to Web GUI the folders were not shared. Checking them in the Web GUI appears to have fixed the sync issue. However, I keep seeing an error in the Web GUI (on the phone) that says:

Global discovery: stat /etc/resolv.conf: no such file of directory; trying again in 1m0s

Can you check what’s the value of the global announce server in the config? It should be an IP and not a hostname, if it’s a hostname, change it to

You’re right, it was Changing it to the IP resolved the error. Thank you.

By the way, the hostname was default after downloading Syncthing (Pulse) from the app store.

@Nutomic mentioned that shouldn’t happen, so I smell a bug somewhere. Same goes with the ‘Share with’ selection, I suggest you raise an issue on his tracker.