photostation on synology can't read folders created by syncthing


Synchronization is working between android folder and synology Nas folder inside photo shared folder.

Syncthing installed with synocommunity docker on DSM 6.x

But I discover that photostation can’t read folder created by syncthing. I mean that I create folders on android and then corresponding folders are created on the last by syncthing. These folders can’t be navigated through photostation. There is no message but folders are seen as empty folders. And even their number doesn’t correspond.

I did a re indexing that will take a long time, I’m not sure it will working and even it couldn’t be the solution because it is too long to perform.

Maybe there is a right problem if syncthing create the folders ?

Just to be clear, did you install the SPK package from SynoCommunity, or are you using Synchting in a Docker container? For the latter, what source did you get the container from?

Installed from synocommunity. Using DSM classic package installer as if it was an official package from synology but package is provided by synocommunity.

I did a new try with a folder created on my phone and Photostation can’t see the new folder. Solution seems to re index everything but is painfully to do

i tried to add my user account in sc-syncthing group but i doesn’t help.

currently all my subfolders are created by syncthing user, half of them can be read by photostation and the other one can’t.

i don’t know why. using ssh and ls -la, I don’t find anything in rights that could explain this.

if re-index my media it will repair it. but it is not a correct solution

That sounds like a limitation in PhotoStation though. It fails to pick up new files into its database and thus doesn’t display them. Might have better luck asking in a Synology forum.

Have you tried to put new files there via SSH for example? Do they get noticed and end up in PhotoStation?

The directory itself is not seen (name of the folder is blank) in Photostation. I thought maybe someone already used syncthing with photo station folder on DMS 6.x In ds file everything is perfect

Problem resolved, photostation (or DSM 6) don’t reindex folder or files when modified by syncthing.

Solution is to create a task to reindex my synchronized folder:

synoindex -R /photo/synchro_portable/sd_card_camera

1 Like

Glad you found a solution. I usually try to stay away from Synology’s custom apps and solutions, exactly because we don’t have much control over how they work in conjunction with other software. Thus never tried PhotoStation myself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.