Permission denied on CasaOS installed syncthing

I’m getting the:

2023-06-29 17:22:55: Failed to create folder root directory mkdir /export: permission denied

2023-06-29 17:22:55: Error on folder zdxnn-vkckt: folder path missing

whilst trying to set up syncthing on CasaOS which is a opensource cloud, which I installed via curl on my raspberry pi 4 running raspbian. CasaOS has there own app store so not sure if syncthing is a snap or .deb etc This is only an issue with pointing to a folder on the externally mounted (by OS) SSD. No permission issues or path issues on the SD card of the pi.

Tried: chgrp, chown, chmod the folder, tried creating a new folder with 777 permissions, also tried pointing to the hard drive via so paths: export/ and srv/dev-disk-by-uuid… Tried scowering the forum.

Any help greatly appreciated, about to tap out lol

Apps for CasaOS aren’t bundled as Snap, Flatpak, DEB, RPM or other package management system, but instead it’s an OCI container (aka., Docker).

It means that Syncthing is running inside a micro Linux system.

In a nutshell, you’ll need to match the directory ownership with the user that the Docker container is running under.

Although a 777 octet for the directory permissions should work (even if it’s the nuclear option :smirk:), the Docker volume must still be configured correctly in order for Syncthing inside the container to access it.

Ahh, think I see now

So syncthing - inside docker - has a owner and I just need to find that out, and create and add that ownership to the dir?

I’ll try that, thank you Sir!

Yes, or alternatively, make the local user match the user inside the Docker container.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.