Period disconnects and reconnects, often with "adjusting curVer 0"

I am using Syncthing in a somewhat unique way. I have two PCs on different networks (ports are forwarded, pingtests pass, files can transfer, so I know that is not the issue). They are set up to sync the same folder on both devices in both directions. So, if I add a file to this folder on either PC, it will sync to the other.

I often see it stop syncing and reconnect within a minute, and the text “curVar 0” appears at the end of the log once it DCs, then it continues with regular "connected to already connected to device " messages. Not really sure what it means. Here is the particularly interesting part:

[LSOBR] 19:47:38 INFO: Established secure connection to <DEVICE_ID> at<DEVICE_IP>:48587
[LSOBR] 19:48:39 INFO: Connected to already connected device <DEVICE_ID>
[LSOBR] 19:49:15 INFO: Puller (folder "Torrents", file "John.Wick.2014.1080p.WEB-DL.DD5.1.H264-RARBG\\John.Wick.2014.1080p.WEB-DL.DD5.1.H264-RARBG.mkv"): pull: no available source device
[LSOBR] 19:49:15 INFO: Connection to <DEVICE_ID> closed: WSARecv tcp An existing connection was forcibly closed by the remote host.
[LSOBR] 19:49:15 INFO: Puller (folder "Torrents", file "Kingsman.The.Secret.Service.2014.720p.WEB-DL.x264.AC3-EVO\\Kingsman.The.Secret.Service.2014.720p.WEB-DL.x264.AC3-EVO.mkv"): pull: no available source device
[LSOBR] 19:49:15 DEBUG: rwFolder/Torrents@0xc0830ae400 adjusting curVer 0

I hope that’s formatted correctly. Any clues?

EDIT: before anyone asks, I know the other PC is not being disconnected from the Internet since pingtests will continue to pass even as the error occurs.

EDIT2: Formatting.

EDIT3: This also comes up sometimes:

[LSOBR] 20:12:38 INFO: Connection to <DEVICE_ID> closed: local error: record overflow

EDIT3: I may have fixed it! If anyone else has this issue, try switching to SyncTrayzor. It functions independently as the regular Syncthing client + more features (including a built in browser). Once installed, your previous Syncthing setup will be carried over. On this client I have not seen the issue crop up and it has been smooth sailing so far.

This means that from the perspective of LSOBR the connection was closed with a TCP reset from the other side. That can be syncthing on the other side experiencing an error and dropping the connection (in which case there should be a more interesting log entry on the side), or it can be an intervening firewall that gets tired of the connection for whatever reason (maybe it think’s it’s been idle too long). That firewall could of course be on one of the end hosts as well.

Don’t worry about anything you see in a DEBUG trace; specifically the “adjusting curVer” etc is normal under the circumstances.

[LSOBR] 20:12:38 INFO: Connection to <DEVICE_ID> closed: local error: record overflow

That’s an error from the TLS (connection crypto) layer. Either a bug in there, or more likely something tampering with the connection. Not necessarily maliciously tampering, might as well just be similar to the above - a firewall closing the connection for example.

Cool. Synctrayzor is awesome, but the underlying syncthing “core” is still the same so it shouldn’t affect the issues above.

That said, in either way, syncthing should reconnect and there’s no major repercussions from the above…

That’s right - Syncthing is still Syncthing under the hood, and SyncTrayzor doesn’t try and affect Syncthing at all in this respect.