Pending changes only on one device shown


my device A shows this: grafik

But device B shows that everything is in sync.

It has been like this for days now and sc was restarted on both devices several times, too.

The devices are connecting and syncing in general.

I tried re-scanning the folder in question (it is just one folder) on both devices but the problem remains.

What’s happening? How to fix this?

Greetings Fred;

Look at the list of not synchronized items and determine, whether they are actually missing on device B (probably not). If they are not missing, you can restart syncthing with the -reset-deltas option and see whether the problem goes away then.

And in general if you have a support request: Please include as many relevant info as possible, at the minimum used syncthing version, which platform you use and probably more. A full screenshot already contains that information as well as metadata from the folders in question, so that’s always a good thing to include (you can always black out sections you don’t want to make public and are irrelevant to the problem).

Ok thanks.

I assume i should use -reset-deltas on device A?

How can i pass these parameters, when starting syncthing with sudo service syncthing@sync start ?

Can i simply append the parameter there? Or is a completely different approach necessary?

p.s. using version v0.14.50 on all devices. Device A is a raspi. Device B is a Windows 8.

Stop syncthing, run the command once manually, start syncthing.

1 Like

Thanks. That worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.