PC and Android devices won't see each other on LAN

I added each other (device ID) on both PC (Linux) and Android phone, but it just says

Disconnected (unused)
Last seen: Never
Address: dynamic
Identification: (something)

when I attempt to get them to see each other over home Wifi. On global relaying it worked fine, but I want over LAN (PC is directly connected to router, phone uses router’s Wifi) so I disabled global discovery and enable relaying options on both ends. I also tried completely disabling firewall, but to no avail, and launching Syncthing with -verbose flag but nothing useful was there. What can I do to further troubleshoot this?

With no detailed information provided on the operating systems in use, I’d guess the problem is probably caused by https://github.com/syncthing/syncthing-android/issues/1628. If that’s the case, then you need to either re-enable global discovery or set static IP addresses in Syncthing for such a configuration to work.

Yeah that was it. Thanks I just used static IPs

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.