Panic of v0.14.45 on FreeBSD 8.3-RELEASE-p5


(Nikolay Nenov) #1

Hello everyone,

I am running syncthing v0.14.45 on a freenas system with version: FreeBSD 8.3-RELEASE-p5 (FREENAS.amd64) #2 r244158M

The version used do work flawlessly before that, no hardware or software change was done to the system meanwhile. The nas is working without issues otherwise.

The system is: |Platform|Intel® Core™2 Duo CPU E7500 @ 2.93GHz| |Memory|8037MB|

Since about March 3 2018 syncthing stopped working with the following email being sent to me:

Could someone please help me resolve this, syncthing has become a major factor in my workflow :slight_smile:

Thank you very much beforehand.


(Jakob Borg) #2

That’s a bug, I filed it. Try to not enable filesystem watching. Also, you should consider something a little less end of life OS-wise… I’m not sure but there’s a good chance that the “not implemented” panic is because it depends on functionality that just doesn’t exist in 8.3.


(Nikolay Nenov) #3

Thanks for your reply. I guessed as much. Just making sure before I invest the time in upgrading the Nas software.


(Jakob Borg) #4

Should still be able to run if you don’t enable the FS watcher, I would guess.


(Nikolay Nenov) #5

Wouldn’t something stop working without the fs watcher?


(Jakob Borg) #6

No, Syncthing has run fine without the FS watcher since forever using just periodic scanning. FS watcher is just a nice to have.


(Nypd) #7

This might be happening to me too. I am running FreeNAS-9.3-STABLE-201605170422 and as soon as syncthing auto updated to v0.14.45 it stopped working (My freenas syncthing plugin does not start at all).

I had to install a new instance of syncthing (v0.14.3) and change the Release Url option to a custom JSON that contains only v0.14.44 as the latest version. Once it updates to v0.14.44 everything works as expected (and my freenas syncthing plugin can start and stop on command)


(Simon) #8

I believe it’s even worse: Disabling fs watcher won’t help as the error occurs at the declaration of a global variable in the notify library.


(Jakob Borg) #9

Oh, that’s not optimal. Can you guys see if this build fixes the panic?

https://build.syncthing.net/viewLog.html?buildId=18129&buildTypeId=Syncthing_BuildLinuxCross&tab=artifacts

If not, a full panic trace would be good. I’m downloading a 9.3 VM to see if I can reproduce it myself.


(Jakob Borg) #10

Works for me on 9.3-p49 now at least.

$ uname -a
FreeBSD freebsd-9.3-amd64 9.3-RELEASE-p49 FreeBSD 9.3-RELEASE-p49 #0: Fri Oct 21 21:01:08 UTC 2016     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

# current master
$ ./syncthing-freebsd-amd64-v0.14.45+25-gb31bad1/syncthing 
panic: function not implemented

goroutine 1 [running]:
github.com/syncthing/syncthing/vendor/github.com/Zillode/notify.newWatcher(0xc42005e240, 0x80, 0xc42005e240)
	/tmp/syncthing-e02d0de3/src/github.com/syncthing/syncthing/vendor/github.com/Zillode/notify/watcher_trigger.go:109 +0x1e8
github.com/syncthing/syncthing/vendor/github.com/Zillode/notify.newTree(0xb5081d, 0x17)
	/tmp/syncthing-e02d0de3/src/github.com/syncthing/syncthing/vendor/github.com/Zillode/notify/tree.go:17 +0x4d

# patched
$ ./syncthing-freebsd-amd64-v0.14.45+27-gd137cd6/syncthing 
[start] 07:55:55 INFO: Generating ECDSA key and certificate for syncthing...
[EKE73] 07:55:55 INFO: syncthing v0.14.45+27-gd137cd6 "Dysprosium Dragonfly" (go1.10 freebsd-amd64) teamcity@build.syncthing.net 2018-03-13 07:23:27 UTC
[EKE73] 07:55:55 INFO: My ID: EKE73YT-4BTZ46V-MEBXBUJ-2XGAH7E-GITR3EQ-6GB4JVZ-QNGY37V-6YMUWAC
...

Should have the patch into .46-rc.1 today.


(Nypd) #11

Installed a new instance of syncthing on my freenas instance. I went from v0.14.3 > v0.14.44 > v0.14.46-rc.1 and I still get my original error where the syncthing plugin does not want to start after updating to the latest version.

I’m not sure if my issue is related to the OP. I’ll try to dig from some logs since FreeNas’s plugin/jail system is a blackbox to me.

Edit: @Nikolay_Nenov where are the logs located on a freenas syncthing jail installation?


(Nikolay Nenov) #12

Hello Nypd,

I have no idea about the jails, I was running syncthing directly on the machine, not in a jail.


(Nikolay Nenov) #13

Hello Jakob,

Many thanks for your help.

Build syncthing-freebsd-amd64-v0.14.45+27-gd137cd6 did not work on

reeBSD freenas_nne.local 8.3-RELEASE-p5 FreeBSD 8.3-RELEASE-p5 #2 r244158M: Wed Dec 12 10:04:42 PST 2012 root@build.ixsystems.com:/home/jpaetzel/8.3.0/os-base/amd64/usr/home/jpaetzel/8.3.0/FreeBSD/src/sys/FREENAS.amd64 amd64

exits with same error:

panic: function not implemented

Let me know how to do the “full panic trace”?

All best,


(Jakob Borg) #14

Just the full output when you run it. Ideally with -no-restart to avoid a bunch failed restarts on top. And be sure to use the right binary, or 0.14.46-rc.1 now. It would be surprising if it still panicked with that build.


(Nikolay Nenov) #15

Hello Jakob,

With syncthing-freebsd-amd64-v0.14.46-rc.1+1-g55a7830 on FreeBSD 8.3-RELEASE-p5 #2 r244158M now the error changed to:

[monitor] 11:13:37 FATAL: stderr: pipe: function not implemented

I guess it’s finally time to upgrade my two NAS boxes. :frowning:


(Jakob Borg) #16

That’s something else, indeed. And try with -no-restart.


(Nikolay Nenov) #17

IT WORKED!

With the -no-restart option it worked :smiley:

You just saved me many hours in reinstalling and reconfiguring of two machines. :slight_smile:

Cheers!


(system) #18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.