Panic error

our server unexpectedly shutdown and when it came back online syncthing didn’t come back up.

When I run it manually I get this error: panic: runtime error: index out of range [1] with length 1

goroutine 1 [running]: main.main() github/syncthing/syncthing/cmd/syncthing/main.go:218 +0x52f

goroutine 6 [chan receive]: github/syncthing/notify.(*nonrecursiveTree).dispatch(0xc000042a20, 0xc000042960) github/syncthing/notify@v0.0.0-20210308121556-f45149b04939/tree_nonrecursive.go:36 +0xb6 created by github/syncthing/notify.newNonrecursiveTree github/syncthing/notify@v0.0.0-20210308121556-f45149b04939/tree_nonrecursive.go:29 +0xe5

goroutine 7 [chan receive]: github/syncthing/notify.(*nonrecursiveTree).internal(0xc000042a20, 0xc0000429c0) github/syncthing/notify@v0.0.0-20210308121556-f45149b04939/tree_nonrecursive.go:81 +0x58 created by github/syncthing/notify.newNonrecursiveTree github/syncthing/notify@v0.0.0-20210308121556-f45149b04939/tree_nonrecursive.go:30 +0x111

goroutine 8 [sleep]: time.Sleep(0x1dcd6500) runtime/time.go:193 +0xd2 github/syncthing/syncthing/lib/dialer.init.1.func2() github/syncthing/syncthing/lib/dialer/internal.go:44 +0x2a created by github/syncthing/syncthing/lib/dialer.init.1 github/syncthing/syncthing/lib/dialer/internal.go:43 +0x15f

I don’t really know where to start. should I reinstall syncthing? Should I delete the syncthing databases? If so what do those files look like? extension? location?


This is a bug in rc.4. You have to upgrade manually (either run with syncthing -upgrade or replace the binary with a newer release): See Immediate crash on start (1.15.0-rc.4) · Issue #7486 · syncthing/syncthing · GitHub

thanks for your immediate reply. it worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.