Panic DB on Primary Sender Machine

Hi There,

I’ve been running this Syncthing configuration for Game updates in my LAN center for a bit over 2 years now.

The Sender PC (1 sender 63 receiveonly PCs) yesterday started getting Panic Messages, and now I can’t get updates across my center.

Tried to rebuild the DB already and it got to the same panic error again.

Also tried -reset-deltas.

Not sure how to go about fixing it so they can start syncing again.

Any help much appreciated thank you!

sysinfoOKG36.txt (5.2 MB)

panic-20220509-160015.reported.log (17.5 MB)

panic: leveldb/table: corruption on data-block (pos=225517013):
 checksum mismatch, want=0x32284d98 got=0x85df488e [file=1870413.ldb]

This essentially says that the block the database read from disk was corrupt. If this is repeatable across a wipe-and-rebuild I think the most likely cause is bad hardware (disks, RAM, motherboard, …), bad drivers, or bad interaction between hardware, drivers and antivirus…

1 Like

Thanks for the reply.

It’s able to fully index without a crash, when the other devices are paused, the error occurs once it starts trying to negotiate with the other connections.

Would that be the expected result of a hardware issue as well?

It’s especially strange(frustrating) that it was working 100% fine for about 2 years and now it can’t process it.

Could be, as other connected devices mean more work.