Override changes failing

I see this: http://screencast.com/t/2yyDI4X2n and when I click on the files that are different I see: http://screencast.com/t/pudOPm2vYG

I click override changes and after a few seconds or more, that notice disappears. It just comes back a few seconds later so not sure how to figure out why this doesn’t work.

Could be some sort of permission problem but not sure how to check/debug

STTRACE=model and the output on that would be interesting. But those are all directory time/permission updates, and that is currently a bit flaky (i.e. https://github.com/calmh/syncthing/issues/356 etc).

Doesn’t really seem to work because if I start:

STTRACE=model /Applications/syncthing 2>&1 | tee /Applications/syncthing.log

as advised here: Keeping Syncthing Running: Mac OS X (LaunchDaemon)

syncthign starts without its configurations its basically empty, doesn’t know about any repositories or nodes so I cannot test the “Override Changes” link or are you still interested in the log file as is? If you would like to see the log file, can I post it here or is there anything sensitive in there?

If you’ve set a HOME environment variable to something nonstandard or normally use the -home option, you need to do that now as well.

Alright, I have succeeded and clicked the “Override Changes” button, waited for it to do its thing the closed it and restarted “normally”.

What shall I do with the log file? its 78MB compressed down to 10MB.

@calmh: what to do with the log?

Hey! Sorry. You can upload it here.

I’d like to but your system says max. upload is 3MB.

Right, I thought I’d fixed that. I’ve increased the limit to 20 megs, I think. Try again?

here you gosyncthing.log.zip (9.9 MB)

Yummy, that’s my evening reading then! :slight_smile:

sorry for that :-/

btw. here’s an idea for a future version: set the different debug levels via the app’s settings page then click the restart button - sounds easier than the current implementation :slight_smile: