Out of Sync warning on device, how to resolve?

Using an SD Card in Android phone which has entire music from an old sync. After changing rom and forgetting to migrate device properly in syncthing removed all sync jobs and re done the setup. I did not remove the music since it is a lot. Since I keepts seeing out of sync info, remove the hidden files to start fresh, removed sync job and set that up again.

mobile device is set to receive only. However, even after setting it up again, still seeing Out of sync as status.

What can I do to resolve this?

It’s really not possible to say anything without more details. Please provide at least screenshots of the Web GUI from both sides showing the folder in question, any error messages, etc. On Android, the Web GUI can be accessed using the left slide-out menu.

Web GUI on mobile had Revert local changes option which I tired but it did not resolve the issue.



I understand the need to obfuscate the path, etc., but why hide the global and local states though? This is important information to verify whether the out of sync items include the whole folder or only a part of it.

Regardless of the above, the first thing I would do is to restart the Android app, then try to revert the changes again, then go to Android/data/com.nutomic.syncthingandroid/files and copy and upload the logfile from there. If you don’t want to upload the whole thing (e.g. for privacy reasons), you will have to analyse it and find the lines related to the revert local changes operation (and why it failed).

Thanks for helping me out.



Out of sync is only part of the entire data. What is odd is that Global state shows 385 GiB while the music folder on desktop is actually over 400 GB.

I have struggled with this few times now, I gave up putting time in it. Simple solution, if you have the other device (not your Android phone) with a complete up to date folder, do this. Just completely delete the folder on your out of sync device. Check de master device, Syncthing has a 1 behind the shared folder that you deleted on the other device. Stop sharing it. Re-share. Accept on the receiving device and re-create the folder. Wait for all the files to re-populate. Do this with power connected just before you go to sleep, on your LAN. It is the most simple way I think.

While your workaround will surely work, please keep in mind that the folder in question is almost 400 GB in size and contains 45,000 files. Even on a fast connection, it’s probably going to take forever to sync all that to the Android device from scratch (especially considering the ridiculous FUSE filesystem restrictions and overhead in Android 11+).

Restarted android app but found no option to revert local changes.


The fact this may take ~2-3 days to re-sync is why I would love to resolve this, since data already exists on SD card. Obviously if this is not successful will have to clear folder and start from scratch.

Your screenshots mention ignore patterns being in place. Sure you’re not just ignoring some files accounting for the difference? Ignoring files is like declaring “I want to be out of sync”, unless the same ignore patterns are applied on all involved devices, from the start.

no, I removed that as well. was ignoring .ds_store files but removed that limitation as well to make sure I am not doing anything wrong in that departement.

Where did you take the 400 GB from? If it’s from a Windows machine, that might be the disk space used, which may be higher than the actual file content sizes. Syncthing only calculates the total content size.

macOS shows folder size and the music folder has a bit over 400 GB.

I would suggest to make sure all your folders on Android are set to Receive Only, then go to the app settings and press “reset indexes”. Syncthing should restart, scan the folders and exchange indexes with remote devices. If that doesn’t help, the atomic option is to “reset database”, also from the app settings. This operation will make Syncthing rehash all the data from scratch which can take a while. It should still be much faster than re-downloading the whole 400 GB again.

1 Like

Where do I find Reset indexes. Tried Reset Delta Indexes and ended up with Syncthing ins't responding.

Edit: it is now opening again and doing a re-scan. Back to out of sync.

Now trying reset database.

When you have set it to Receive Only, as suggested by @tomasz1986 for extra caution, it will naturally end up Out Of Sync if there are any differences. You should inspect them first, possibly everything would have worked again after resetting to send-receive. Screenshots always help us judge the situation, especially look at the list coming up when you click the out of sync items in the folder GUI.

I don’t want to sync back any changes from mobile to desktop. This is a one-way train (from desktop to mobile) and that is perfectly fine. Wouldn’t receive only bring changes from desktop to mobile and resolve out of sync?

Not automatically. You should be presented with a “Revert Local Changes” button, and only if you press it, the local changes should be removed. Please post a new screenshot from Android after the database reset once scanning has finished and everything has been rehashed.

scan just finished. mobile web GUI:

All conflicts seem to have resolved. All folders show with green checkmark in web GUI.

This is awesome. Thanks so much for walking me through this process and helping me get back to working state without having to do a fresh sync from scratch.

Glad to hear that the problem has been resolved, and so quickly :slight_smile:.

1 Like