Out of Sync items on mobile after resetting sync job

Need to reset all folders on one device of two devices syncing.

Mobile got messed up so the idea is to remove all content in the respective folders on the mobile (needs to be reset) and re-share from laptop (folders ok).

To do that

  1. unshare mobile device from desktop
  2. remove folder from syncthing on mobile
  3. remove all files in that folder on mobile

The idea was to now share again with mobile, select the empty folder, set to receive only on mobile and have all files transferred to mobile.

To do that

  1. share folder on desktop with mobile
  2. accept via notification on mobile
  3. for directory on mobile select the empty folder the files should be synced to
  4. allow permission
  5. set to receive only
  6. tap checkmark to store

On mobile I then see:

  • sync-preparing
  • the first oddity: I see ~1300 files on desktop for this folder, but mobile shows ~37k files with 23 GiB, wondering where that info is coming from, but I let it do it’s thing
  • syncing…
  • out of sync warning

Now I am unsure why that is. I switch to WebGUI on mobile and this is were I get lost. Desktop does not show any problem, shows mobile device as “Up to Date”. Mobile shows 18 GiB Out of sync items. But I don’t see any option to resolve this problem.

How can I proceed from here to resolve this and get back to working state?

Tried a saner approach:

  • remove folders from syncthing on mobile + desktop
  • remove all files from camera folder on mobile (including hidden files)
  • copy files that should be in that folder to that folder on mobile (from a backup)
  • empty target folder on macos including all hidden files
  • create new folder on mobile
  • share with desktop
  • sync starts and completes without issues

Trick was to start with a clean slate. Lucky if you have a backup. Not to self: next time, don’t mess up a working setup. Blessed be those who have backups.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.