Out of Sync items due to permission denied on temp file creation

Hello. I’ve just added a new syncthing node to my existing network.

The shared folder synced correctly on the new node, but then I created a new file on another node and this made the new node show the “Out of Sync” error. In the Failed Items list the new file is the one out of sync, with reason “permission denied” and this message showing up on mouseover: “syncing: opening temp file: open /mnt/qnap/STCloud/folder/filename.txt.tmp: permission denied”.

The folder resides on a NAS and it’s mounted on the computer via NFS, but I think I gave all the needed permissions, in fact I can write to that folder without problems.

Any suggestions? Thank you

Ok, mounted the share via Samba instead of NFS and the problem disappeared. Would still like to understand why it didn’t work with NFS though.

I think smb has very little if yamy permission support on linux, where as NFS does support full unix permissions, so I think the permission issues are genuine when mounted as NFS.

I understand that, but the user has r/w permissions on that disk, so I don’t understand what might cause the problem. Luckily the folder in question only contains a (huge) bunch of files for which permissions are not important if not completely useless.

“disk” doesn’t have much meaning, the user needs to have read write execute perms on the folder.it’s working it, and potentially even own it for certain operations (i.e., changing permissions, you can’t change perms on things you don’t own).

I realize that, that’s why I specified that I tried writing to that folder and it worked flawlessly. I really don’t understand what permission is missing…

Well, I don’t have enough details to tell you. I’ve explained what permissions are needed.

I see. I’ll double check, but the user has read, write and execute permissions. It does not have ownership, but I don’t think I can fix that.

You might need to check “ignore permissions” on the folder settings, as setting permissions requires ownership.

Thanks.

Just a clarification: would checking “ignore permissions” obtain a different goal than using Samba? What are the differences in this case?

Thank you for your time.

It simply does not sync the permissions as the documentation suggest. The files get created and get permissions from umask.

Got it. Thank you very much.