OS-X - access to folder under user library


(Robert Smith) #1

I am trying to sync the Excel personal macro file. Excel requires that it be in a folder under the user library (putting it somewhere else does not help as it’s not possible to redirect the location within Excel). Syncthing fails in 2 ways: 1) it can’t make a directory from the root (although occasionally it does by creating a second Library folder, which is not useful), or 2) simply can’t access the file under library (permission denied error). Perhaps there is some terminal command that would grant syncthing access to the library folder and its contents?


(Jakob Borg) #2

Syncing stuff under ~/Library (in your home directory) should work fine, while /Library (at the disk root) is mostly read only to normal users. Which is it you’re trying to do? Screenshots might help.


(Robert Smith) #3

I am trying to share the XL startup file that contains XL macros. I am unable to tell XL where to find this file, so am stuck with the location hard coded into XL.

The screen shots show my creation of a folder for syncthing, and then the following messages. (Note - I closed and restarted syncthing after creating the folder for synctying).

In Mac’s Finder, I have set the library to be viewable in Finder.

Thank you for looking into this issue. Please let me know if I can provide any further information.

I look forward to hearing from you.

Bob


(Jakob Borg) #4

Your path /Users/iMac1510Library/... is wrong and points to a hypothetical user called “iMac1510Library”. You want /Users/iMac1510/Library/..., note the extra slash, or just ~/Library/... which is equivalent.


(Robert Smith) #5

You’re quite right about the missing ‘/’. I attempted to recreate the problem today, and was sloppy. Please see the attached: you will note that syncthing created a redundant ‘library’ folder/path, that can’t be accessed by XL. Yesterday - with the proper backslashes, this second library phenomenon occurred, but not always.

Now I seem to be limited to 1 upload file. - to more replies to follow…


(Robert Smith) #6


(Robert Smith) #7


(Jakob Borg) #8

I’m not sure how exactly, but there’s something wrong about the “Library” you’ve told Syncthing to sync. Perhaps some hidden space or odd unicode character that looks like a regular one. It’s not possible to have two folders beside each other both called “Library”.


(Robert Smith) #9

I obtained the path by browsing to it, ‘get info’, and cut/pasting the path into syncthing. When that didn’t work, I then tried eliminating the user by substituting the ‘~’ (both of these several times, and usually, the second library folder was not created. And I then tried to do the same thing on my notebook computer, with the same results. The paths on the two computers are identical with the exception of the first folder under ‘group containers’. When I tried to place the folder I want to synchronize under user/sync, Excel couldn’t find it, and googling, there is no mention of how I can redirect Excel to a different location. The common denominators are 1) me, 2) os-x, and 3) syncthing.


(Jakob Borg) #10

This means you did it right. Use that variant.


(Robert Smith) #11

The ‘right’ variant does not work. Amongst the screenshots previously posted is the message that the file / path can’t be found (paraphrasing) when using the ‘right’ variant. That’s why I originally suggested that perhaps the solution is a command in terminal that would open the library path up to Syncthing.


(Jakob Borg) #12

There’s no error shown that indicates the right path being tried. But apart from that I have no idea what’s going on, sorry.